Installation issue Mac

Hi everyone, I'm a new user of QIIME2. When I try to install QIIME2 on my Mac I get the following error:

angelamaffia@MacBook-Air-di-Angela ~ % conda env create -n qiime2-amplicon-2023.9 --file qiime2-amplicon-2023.9-py38-osx-conda.yml
Collecting package metadata (repodata.json): done
Solving environment: failed

ResolvePackageNotFound:

  • fasttree=2.1.11
  • vsearch=2.22.1
  • bioconductor-dirichletmultinomial=1.40.0
  • bioconductor-beachmat=2.14.0
  • bioconductor-biostrings=2.66.0
  • q2-metadata=2023.9.0
  • r-energy=1.7_11
  • q2-taxa=2023.9.0
  • blast=2.14.1
  • bioconductor-sparsematrixstats=1.10.0
  • q2-fragment-insertion=2023.9.0
  • q2galaxy=2023.9.0
  • r-rsqlite=2.3.1
  • bioconductor-scuttle=1.8.0
  • iow=1.0.5
  • perl-io-compress=2.201
  • r-rcppml=0.3.7
  • q2-quality-control=2023.9.0
  • q2-feature-classifier=2023.9.0
  • perl-compress-raw-zlib=2.202
  • r-rcpphnsw=0.5.0
  • q2-types=2023.9.0
  • perl-storable=3.15
  • bioconductor-biobase=2.58.0
  • mafft=7.520
  • q2-cutadapt=2023.9.0
  • samtools=1.17
  • bioconductor-iranges=2.32.0
  • q2-diversity=2023.9.0
  • bioconductor-dada2=1.26.0
  • unifrac=1.3
  • r-scs=3.2.4
  • bioconductor-delayedarray=0.24.0
  • htslib=1.17
  • sortmerna=2.0
  • bioconductor-multtest=2.54.0
  • unifrac-binaries=1.3.1
  • sepp=4.3.10
  • r-ade4=1.7_22
  • perl-json-xs=2.34
  • bioconductor-shortread=1.56.0
  • q2-longitudinal=2023.9.1
  • q2-quality-filter=2023.9.0
  • iqtree=2.2.5
  • q2-phylogeny=2023.9.0
  • cutadapt=4.4
  • q2cli=2023.9.1
  • bowtie2=2.5.1
  • emperor=1.0.3
  • bioconductor-zlibbioc=1.44.0
  • biom-format=2.1.14
  • q2-feature-table=2023.9.0
  • r-cvxr=1.0_11
  • r-ecosolver=0.5.5
  • q2-dada2=2023.9.0
  • q2-mystery-stew=2023.9.0
  • bioconductor-rhtslib=2.0.0
  • perl-compress-raw-bzip2=2.201
  • q2-alignment=2023.9.0
  • perl-scalar-list-utils=1.63
  • bioconductor-xvector=0.38.0
  • scikit-bio=0.5.8
  • r-osqp=0.6.3
  • q2-diversity-lib=2023.9.0
  • r-gsl=2.1_8
  • ncbi-vdb=3.0.0
  • bioconductor-biocsingular=1.14.0
  • q2-demux=2023.9.0
  • bioconductor-rhdf5=2.42.0
  • isa-l=2.30.0
  • bioconductor-decipher=2.26.0
  • qiime2=2023.9.1
  • bioconductor-rhdf5lib=1.20.0
  • q2-deblur=2023.9.0
  • bioconductor-s4vectors=0.36.0
  • raxml=8.2.12
  • dnaio=1.0.0
  • q2-sample-classifier=2023.9.0
  • xopen=1.7.0
  • q2-composition=2023.9.0
  • bioconductor-rsamtools=2.14.0
  • entrez-direct=16.2
  • q2-emperor=2023.9.0
  • bioconductor-biocneighbors=1.16.0
  • bioconductor-genomicranges=1.50.0
  • perl-pathtools=3.75
  • perl-list-moreutils-xs=0.430
  • perl-encode=3.19
  • bioconductor-genomicalignments=1.34.0
  • q2templates=2023.9.0
  • q2-vsearch=2023.9.0
  • python-isal=1.3.0
  • bioconductor-biocparallel=1.32.5
  • bioconductor-rhdf5filters=1.10.0
  • hmmer=3.1b2

I have just installed the latest version of miniconda and I have done the update.

Thank you,
Bye :slight_smile:

1 Like

Hello @Angelamaffia,

Do you know if your Mac is an m1/m2 Mac or an intel Mac? If you don't know you can run uname -m in your terminal and then post the output here.

Can you also run conda config --show subdir and conda config --show channel_priority and post the outputs?

2 Likes

HI,

I was having the exact same issue, but on a Linux environment. What worked for me was instead of using conda to install the environment, I used mamba. Worked without a hitch. Maybe worth a try for your problem?

Cheers,
Laura

1 Like

Hello,
I am also having installation issues on my Mac (and am also new to the qiime community).
Feel free to split this into a new topic.

I'm trying to install the amplicon-2023.9 distribution on an M1 Mac with Terminal.
I installed the latest version of miniconda3 and updated conda. I successfully installed wget, and successfully downloaded the .yml file with wget. However, I cannot get the next line of code (CONDA_SUBDIR=osx-64 conda env create...) to run without conflict/error "incompatible packages/ package conflicts", which lists every package (and takes about 40 minutes to run), and ends with "your installed version is: not available".

I tried it again after clicking "open using Rosetta" for my terminal (Finder > Apps > Terminal info) & restarting terminal, but had the same errors. I also tried creating the env with just (conda env create), not including (CONDA_SUBDIR=osx-64), same error. I also tried (conda create) without "env", different error.

I ran the lines @colinvwood suggested as well:

Thanks everyone! I'm so grateful that this community exists!

1 Like

Hello @Taylor_Akers,

I don't think you're on an M1 Mac but an intel Mac (your uname says x86 which is an intel architecture). That being said, following the m1 install instructions when you don't have an m1 should be fine...

Can you run conda --version and post the output?

Hello @colinvwood, yes of course


Also, when I go into "About this Mac", it says Apple M1 for the chip.

Hello @Taylor_Akers,

Try the same conda installation command as before with the additional option: --solver libmamba, that should resolve your solving error.

As far as the m1 Mac thing, I forgot that you had opened the terminal with rosetta, so I think that's what's going on there.

1 Like

Hi @colinvwood ,
Thank you for the suggestion.

I tried adding --solver libmamba to the end of the CONDA_SUBDIR=osx-64 conda env create... command and got a different error, "Error while loading conda entry point"..."have 'x86_64', need 'arm64"... I read a bit about it online to troubleshoot. However, when I ran arch, it lists "arm 64". I also tried conda info to back track and got the same error.

It seems as though I broke my conda somehow.. I read online that I might have more luck with miniforge/mamba... So I decided to rm miniconda3 completely & also from my .bash_profile. Then I downloaded the latest miniforge3 for arm64, following these GitHub instructions (yes, I restarted Terminal after).

I then installed the libmamba package following these instructions with conda install -n base conda-libmamba-solver. That seemed to work, but I got a warning that a newer version of conda exists - which seems odd, since I just downloaded it from their site. Anyway, it gave me a suggested update code & I ran it: conda update -n base -c conda-forge conda. Oddly, I got the same warning after that...

I decided to continue anyway & I set libmamba as my default solver with conda config --set solver libmamba. No errors or anything, so I proceeded to install wget with no issues. Then used wget to pull the qiime2.yml file from the Qiime2Docs Install page, no issues & I see the .yml file when I ls. Next, the same problematic step as before, creating the env... I ran CONDA_SUBDIR=osx-64 conda env create -n qiime2-amplicon-2023.9 --file qiime2-amplicon-2023.9-py38-osx-conda.yml as listed, and got warnings:


For so many lines... then the "unsatisfiable error" for so many lines...

Then a lot more red...

I ran it again with --solver libmambaat the end of the conda env create line (even though I set libmamba as my default server) and got the same lines of warning/errors.

In general I'm wondering: is it the M1 chip that is having issues? Is it me because I'm so new to programming/qiime and not running things correctly?

This is a side convo/ comment: My bioinformatics professor suggested I use AWS (that's what we used in class - fall 2022- and I installed the then current qiime version just fine).
However, i just read the related note on the docs page:


So now I'm wondering, since I'm having so many install issues with my Mac, would I be better off learning to use Docker & working with qiime2 in there instead? Or should I try to install an older version of qiime2 on my mac, since I successfully got that to work before?

I so appreciate all your advice/help! I really want to learn & work with qiime, but I've been stuck at the install step for 2 weeks now.

~ Taylor

Hi, I'm sorry to bother you with a simple semantics question!

Yes, the language is confusing... in this case, when you refer to mamba, libmamba and conda - are you refering to the full Anaconda or the miniconda3 that is suggested to be used on the Qiime2 Docs instal page? Or does it matter?

In a related post: installation issue Mac (on M1 chip). I had issues and tried --solver=libmamba, and still had issues. So I removed miniconda3 and tried downloading the qiime2 amplicon distro with miniforge3/mamba instead (after installing libmamba & setting it as the default solver), and still had issues..

So now with the semantics question.. I'm wondering was my miniconda3 insufficient & should I try installing the full Anaconda instead?

Thank you!

Hello @Taylor_Akers,

What works for me on an m1 Mac is installing mambaforge (now miniforge) and then using mamba instead of conda to perform the installation, without messing with any other variables (not setting any config files, not opening terminal with rosetta, etc.).

2 Likes

I was able to solve this problem on my m1 mac (using miniforge3) by running conda config --set channel_priority flexible before following the regular m1 installation instructions, e.g.

wget https://data.qiime2.org/distro/amplicon/qiime2-amplicon-2023.9-py38-osx-conda.yml
CONDA_SUBDIR=osx-64 conda env create -n qiime2-amplicon-2023.9 --file qiime2-amplicon-2023.9-py38-osx-conda.yml
conda activate qiime2-amplicon-2023.9
conda config --env --set subdir osx-64

3 Likes

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.