install qiime2-2023.2 errors on M1 after following all instructions

I have been trying to install the new version of qiime2 for the past couple of days and have tried the tips from this forum with no solution. I have used the qiime2-2022.11 and 2022.8 version successfully with no install problems so I am not sure what is happening.

I specifically followed this post as I am using an M1 mac Install QIIME2 on Macbook Pro 2021 with apple M1 Chip which ran the "Found conflicts! Looking for incompatible packages." much faster (1hr vs 4+ hrs) than any of the other instructions I tried.

It resulted in over 20,000 lines of error so I won't copy and paste but maybe this file will work:
qiime2installerrors.txt (2.3 MB)

I did update conda before doing the install of qiime2. I have also tried completely removing miniconda3 several times and re-installing it before I switched to miniforge3. I also tried removing miniforge3 and re-installing. I am using terminal with rosetta2.

Can anyone provide some help?

Hi @jdv,

Welcome to the :qiime2: forum!

Sorry to hear about your difficulties installing QIIME 2!

Let's have you try a couple of things:

  1. Try using the install instructions for macOS (Intel) and OS X and see if that is successful.
  2. Try running conda clean --all before attempting to re-install.

If neither of these work, can you provide the output from your terminal after running conda env list?

Cheers :lizard:

1 Like

Hello! I did steps 1 and 2, it ran for about 3 hrs and did not install.

Here is the output for conda env list

conda environments:

base /Users/jessicadiaz/miniconda3

Hello @jdv,

I have an m1 MacBook, and have a working installation of 2023.2. I had some problems previously with a miniconda installation :snake::microscope:, and replaced that with anaconda :snake:.

If you have the space and don't mind getting rid of your miniconda installation, you could try this. I followed the the standard Mac installation instructions (the "macOS (Intel) and OS X" tab here).

Hope this works for you.

Thank you for the suggestion! Did you install anaconda with the rosetta2 activated?

Hey @jdv,

I had the same struggle with updating from qiime2-2022.11 to 2022.8 on my Macbook Pro 2021 M1 :upside_down_face:. After updating conda I wasn't even able to run "conda info". I deactivated/deleted conda and any other qiime2 folder/info on my lapotop. Afterwards I restarted my macbook, installed miniconda and qiime2-2023.2 following the instructions and it worked. Make sure rosetta2 is activated :slight_smile:
Check out this link: Install QIIME2 on Macbook Pro 2021 with apple M1 Chip; maybe it can help you.
I really hope this helps! :hugs:

@aliral Thank you! :slight_smile: This worked for my current user profile, I had to delete everything and restart. I installed anaconda instead of miniconda.

Before this solution, I also created a new user on my mac with admin privileges and only installed anaconda and qiime2 and that ran successfully. I think I'll keep working out of the new user for all my terminal & qiime2 needs just to be on the safe side that other apps are not interfering. It seemed that having R installed as an app (for Rstudio) was causing issues due to different versions of R with conda?

Thanks everyone for the quick help!!

1 Like


Glad you were able to get things working!

Yes, this can definitely happen if you have separate R instances installed - those can compete within conda, causing conflicts that don't exist in the environment itself.

For utilizing R separately from QIIME 2, I prefer to create a specific conda environment with R installed - this helps to keep things separate and prevents conflicts such as what you ran into above.

Cheers :lizard:

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.