Install issues - miniconda in WSL

Hi,

I am having some challenges getting Qiime2 running in WSL. I have installed WSL, and installed miniconda3 within WSL. Where I am getting stuck is at the point of update conda - I consistently get the error:

[email protected]:~$ conda update conda
Collecting package metadata (current_repodata.json): failed

CondaHTTPError: HTTP 000 CONNECTION FAILED for url https://repo.anaconda.com/pkgs/main/linux-64/current_repodata.json
Elapsed: -

An HTTP error occurred when trying to retrieve this URL.
HTTP errors are often intermittent, and a simple retry will get you on your way.

If your current network has https://www.anaconda.com blocked, please file
a support request with your network engineering team.

'main/linux-64'

What I have tested so far:

*Basic bash commands work as expected in WSL (ls, head, mkdir, etc.)

*Conda exists and WSL can find it:
[email protected]:~$ conda --version
conda 4.12.0

*WSL seems to be able to access the internet
[email protected]:~$ ping 8.8.8.8 PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data. 64 bytes from 8.8.8.8: icmp_seq=1 ttl=55 time=278 ms 64 bytes from 8.8.8.8: icmp_seq=2 ttl=55 time=357 ms 64 bytes from 8.8.8.8: icmp_seq=3 ttl=55 time=369 ms 64 bytes from 8.8.8.8: icmp_seq=4 ttl=55 time=288 ms 64 bytes from 8.8.8.8: icmp_seq=5 ttl=55 time=311 ms 64 bytes from 8.8.8.8: icmp_seq=6 ttl=55 time=334 ms 64 bytes from 8.8.8.8: icmp_seq=7 ttl=55 time=292 ms ^C --- 8.8.8.8 ping statistics --- 7 packets transmitted, 7 received, 0% packet loss, time 6006ms rtt min/avg/max/mdev = 277.793/318.287/368.772/32.838 ms

*The problem is persistent over time (tried several times over the last 15 hrs)

*skipping update and jumping straight to install wget leads to the same error

*logging on to my work VPN doesn't solve it, so unlikely to be a network specific problem, or related to location (work VPN is in Europe, "normal" wifi connection is in Australia)

*Using my web browser (not in the WSL) I seem to have no problems accessing the Anacondas website, so it seems unlikely the site is somehow blocked by our internet service.

Any suggestions would be very much appreciated!

Alison

Hello Alison,

Welcome to the forums! :qiime2:

My first thought was that this computer was off line, so I'm glad you confirmed your computer can reach 8.8.8.8

Are you able to reach these anaconda specific addresses?

ping repo.anaconda.com

curl https://repo.anaconda.com/pkgs/main/linux-64/current_repodata.json | head
1 Like