Install HTTP connection failed

Hi, I had the same issue after updating conda. I was able to download the file, but now I get an error when conda attempts to create a new environment.

conda env create -n qiime2-2019.1 --file qiime2-2019.1-py36-linux-conda.yml
Collecting package metadata: done
Solving environment: done

Downloading and Extracting Packages
q2-fragment-insertio | 180.3 MB | #7 | 5%

CondaHTTPError: HTTP 000 CONNECTION FAILED for url https://conda.anaconda.org/qiime2/label/r2019.1/linux-64/q2-fragment-insertion-2019.1.0-py36_0.tar.bz2
Elapsed: -

An HTTP error occurred when trying to retrieve this URL.
HTTP errors are often intermittent, and a simple retry will get you on your way.

I’ve done this many times before with no error, so I’m assuming the issues are related. Any suggestions on how to work around this?
Thanks

Hi @Anne_Ballou,
The error you are receiving is probably not related, so I have moved it to its own topic.

We have seen this type of connection error reported several times. The most likely explanation is that your network connection is unstable and the connection was broken while you were attempting to download/install packages. Since this has worked for you before, I suspect that’s the cause and you should just follow the advice in the message:

But if you are failing repeatedly where you’ve been successful in the past, there could be another issue, and various users have reported this to be caused by firewalls or other issues that can be fixed. You can see what others have done who have run into this same error:
https://forum.qiime2.org/search?q=HTTP%20000%20CONNECTION%20FAILED%20for%20url%20

Good luck!

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.