In 2020: An error was encountered while running DADA2 in R (return code 1), please inspect stdout and stderr to learn more.

Cordial greeting.

I got next error after run denoise command in my paired-end sequences

An error was encountered while running DADA2 in R (return code 1), please inspect stdout and stderr to learn more.

I have read and it is mentioned that this issue is when paired-ends are not well joined.
I have uploaded my demux.qzv file.
I used different parameters, soft and strong and I cannot understand why it is still happening.

Thanks for the helpdemux.qzv|attachment (288.1 KB)

Hi @amaria.gallego!

Sorry to hear that! We are missing a lot of important information to help you with this issue:

  • What is the exact command or commands you ran? Copy and paste please.
  • What is the exact error message? If you didn’t run the command with the --verbose flag, please re-run and copy-and-paste the results.

It looks like the upload didn’t work, can you try again?

Thanks!

:qiime2:

Hi @thermokarst

Thanks for the answer, here the things

  1. Command ran in HPC cluster

qiime dada2 denoise-paired
–i-demultiplexed-seqs paired-end-demux.qza
–p-trim-left-f 4
–p-trim-left-r 4
–p-trunc-len-f 207
–p-trunc-len-r 204
–o-table table.qza
–o-representative-sequences rep-seqs.qza
–o-denoising-stats denoising-stats.qza

  1. I got an issue with --verbose flag it says command not found, where should I add the flag? at the beginning or at the end of the command?

  2. I added again the demux.qzv filedemux.qzv (288.1 KB)

Thanks

Thanks @amaria.gallego

You can add it anywhere after the qiime dada2 denoise-paired. The error you shared here indicates that you didn’t format the command correctly (don’t forget to include \ at the end of the line if you are splitting the commands across multiple lines, as you showed above).

qiime dada2 denoise-paired \
  --i-demultiplexed-seqs paired-end-demux.qza \
  --p-trim-left-f 4 \
  --p-trim-left-r 4 \
  --p-trunc-len-f 207 \
  --p-trunc-len-r 204 \
  --o-table table.qza \
  --o-representative-sequences rep-seqs.qza \
  --o-denoising-stats denoising-stats.qza \
  --verbose

Dear @thermokarst thanks for the email, in fact the code has \ at the end of all lines, I forgot to added into the post.

Still I am having the error, here the code with – verbose

Conda uses environments to load different sets of Python packages

type conda env list to see the environments availible.
type source activate env_name to activate the environment.

Loading required package: Rcpp
Error in (function (fn, fout, maxN = c(0, 0), truncQ = c(2, 2), truncLen = c(0, :
Mismatched forward and reverse sequence files: 70067, 70068.
Execution halted
Traceback (most recent call last):
File “/BIOS-Share/Software/devtools/bioconda/miniconda3/python3.7/envs/qiime2_2010_env/lib/python3.6/site-packages/q2_dada2/_denoise.py”, line 257, in denoise_paired
run_commands([cmd])
File “/BIOS-Share/Software/devtools/bioconda/miniconda3/python3.7/envs/qiime2_2010_env/lib/python3.6/site-packages/q2_dada2/_denoise.py”, line 36, in run_commands
subprocess.run(cmd, check=True)
File “/BIOS-Share/Software/devtools/bioconda/miniconda3/python3.7/envs/qiime2_2010_env/lib/python3.6/subprocess.py”, line 418, in run
output=stdout, stderr=stderr)
subprocess.CalledProcessError: Command ‘[‘run_dada_paired.R’, ‘/tmp/tmpy22zjuo8/forward’, ‘/tmp/tmpy22zjuo8/reverse’, ‘/tmp/tmpy22zjuo8/output.tsv.biom’, ‘/tmp/tmpy22zjuo8/track.tsv’, ‘/tmp/tmpy22zjuo8/filt_f’, ‘/tmp/tmpy22zjuo8/filt_r’, ‘207’, ‘204’, ‘4’, ‘4’, ‘2.0’, ‘2.0’, ‘2’, ‘consensus’, ‘1.0’, ‘1’, ‘1000000’]’ returned non-zero exit status 1.

Can you help me please?

thanks in advance!

Hi @amaria.gallego - --verbose won’t “fix” the command for you, it will return a lot of detailed “verbose” logging output - I need this output in order to help you (so that I can see what is going wrong). It looks like you copied some of that here, but please rerun and copy everything. You can use the command block I shared in my post above.

EDIT:

Actually, no need to rerun, even though you didn’t send everything, I think the key piece of information is right here:

Apparently one of you samples has one fewer reads in the forward direction than in the reverse. How were these sequences pre-processed, prior to DADA2?

Dear @thermokarst thanks for the answer.

Respect to

Hi @amaria.gallego - --verbose won’t “fix” the command for you, it will return a lot of detailed “verbose” logging output - I need this output in order to help you (so that I can see what is going wrong). It looks like you copied some of that here, but please rerun and copy everything . You can use the command block I shared in my post above.

I know verbose wont fix the command, in fact I ran the command you provided before and I paste the ALL output above.

In the other hand respect to the pre-processed prior to DADA, I got an issue with one of my fastq files where you gave me an answer in other post. The issue was that I got an empty read thus I modified the fastq file removing this empty read. After that, the import in QIIME worked perfectly, so now the problem with DADA is because of that.
At this moment I am not sure how proceed

thanks

Hi @amaria.gallego!

Great! I just wanted to make sure, since your comment above (“Still I am having the error”) sounded like you expected it to work after including --verbose - I realized I didn’t clarify what the --verbose flag was for, and wanted to make sure you knew - no offense was intended!

Strange - there should be a lot more to that error message - in the future I recommend that you carefully review all of the output before copying and pasting - and in general its usually better to send us too much information, rather than too little!

Ah yes, are you referring to this?

I’m not sure how you edited your file in order to fix it, but I suspect that it just postponed the actual issue. Have you specifically contacted the sequencing center and asked about that empty read? Your best bet is to solve the problem at the source - the raw sequencing data.

Good luck and keep us posted!