Importing single-end multiplexed fastq files

Greetings

I am new to all this. I have a fastq files containing multiplexed single-end reads obtained from an Ion torrent PGM machine. I also have a metadata txt file that seems to match the format requirements for using qiime2. My goal is to make OTU level analysis once the data is demultiplexed and cleaned.

However I have been incapable of importing the data.

After looking the moving pictures tutorial (and also checking that it ran in my computer) and reading several forums, I haven’t been able to even import the files. The last command I used was:

qiime demux emp-single
–i-seqs Manifest1.txt
–m-barcodes-file DATOS_OTUS/chip1_mp_corrected.txt
–m-barcodes-column BarcodeSequence
–o-per-sample-sequences demux1.qza
–o-error-correction-details demux1-details.qza

The error that showed this time is this:
(1/1) Invalid value for “–i-seqs”: ‘Manifest1.txt’ is not a QIIME 2 Artifact
(.qza)

If I first try to import the manifest file with qiime import:
qiime tools import \

–type ‘SampleData[SequenceWithQuality]’ \

–input-path Manifest1.txt \

–output-path ION1-mux.qza \

–input-format SingleEndFastqManifestPhred33V2

this error appears:
An unexpected error has occurred:

Semantic type SampleData[SequenceWithQuality] does not have a compatible directory format.

See above for debug info.

Im not sure what I must do and I ran out of ideas.
Any help?

Hi, @jd.lozano,

The first thing jumps out to me is a typo in your import command. Compare the string that you passed to --type with the list of importable types, which you can view with qiime tools import --show-importable-types.

You can find more details about this type of import at https://docs.qiime2.org/2020.2/tutorials/importing/#fastq-manifest-formats

Hello,

It worked after a couple of other tweaks to the files. However at the end I used
qiime tools import
–type MultiplexedSingleEndBarcodeInSequence which was easier apparently.

Thanks! :tada: