Importing seqs.fna

@wasade and @ebolyen, was a solution added to Q2 for this? I’m trying to import in the seqs.fna file from QIIME 1.9.1’s

I tried the following, but errored out.
qiime tools import
–input-path seqs.fna
–output-path seqs.qza
–type ‘SampleData[Sequences]’
–source-format DNAFASTAFormat

Hi @sejsong,

I think I see the problem, but without the error I can’t be sure, could you post the error you are receiving?

Your import is almost correct, but you are probably seeing something wonky about how there’s no transformer between DNAFASTAFormat and QIIME1DemuxFormat. Since your data is already from you can just remove the --source-format option entirely (or set it to QIIME1DemuxFormat instead of DNAFASTAFormat).

Ah, yes, that did it. I must have overlooked QIIME1DemuxFormat in the list of options.

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.