Importing Joined Data from Manifest for Ion Torrent

I have tried importing Ion Torrent fastq file with

 qiime tools import   \
        --type 'SampleData[JoinedSequencesWithQuality]'   \
        --input-path XYZ.fastq \
       --output-path single-end-demux.qza \ 
      --source-format SingleEndFastqManifestPhred33

However, this gives an error saying:

** XYZ.fastq is not a(n) SingleEndFastqManifestPhred33 file**

I have a single fastq file with all data for 90 some samples. Can anyone who successfully imported ion torrent data tell what was their files like and etc…

first 20 lines of my fastq file is like this:

@47OC4:03984:00163
TCCTCGAATCGATGGACTACCAGGGTATCTAATCCTGTTTGATACCCACACTTTCGAGCATCAGCGTCAGTTACAGTCCAGCAAGCTGCCTTCGCAATCGGAGTTCTTCGTGATATCTAAGCATTTCACCGCTACACCACGAATTCCGCCTTGCCTCTACTGTACTCAAGACACCCAGTATCAACTGCAATTTTACGGTTGAGCCGCAACTTTCACAACTGTACTTAACATCCATCTACGCTCCCTTTAAACCCAATAAATCCGGATAACGCTGGATCTCCGTATTCCGCGGCTGTGCACGGAGTTAGCGACTCCTTCTTTCATTAAGACAATGCAAAATCGGAGTTCCTCATTACCCGCTTTATTCTTATAAAAGAAAGTTTCACCCATAGGCAGTCTCCTTCACTC
+
@@[email protected]@@A>@@@B<<7;99::.555)5=<=AC?CB<@@[email protected]@@@;@BBCCCCBCBCBBBCBB?BBBBAB>[email protected][email protected]@??=?3::99<@@@=AAA;??>[email protected]<@A???8?AA>?;;===?:?>;;769>5::)/)//)/:;;A>>>@@???:==<;67.799///8389:<=0888)5==:A<==89*/--)---'---9488---22(-(-222055-..;;9555)22)2:0:=083222)2:49266744-,*5(***,2,253338.....3776657..*.896658:7999181775,569.715776---6666),,2,,,,02022222444*-.48.88-..056699+222,226'--27.6788232,,,**(((**,-2
@47OC4:03984:00165
TCCTCGAATCGATTCCTACGGGAGGCAGCAGTGGGGAATATTGGACAATGGGCGAAAGCCTGATCCAGCCATGCCGCGTGTGTGAAGAAGGTCTTCGGATTGTAAAGCACTTTAAGTTGGGAGGAAGGGCATTAACCTAATACGTTAGTGTCTTGACGTTACCGACAGAATAAGCACCGGCTAACTCTGTGCCAGCAGCCGCGGTAATACAGAGGGTGCAAGCGTTAATCGGAATTACTGGGCGTAAAGCGCGCGTAGGTGGTTTGTTAAGTTGAATGTGAAATCCCGGCTCAACCTGGGAACTGCATCCAAAACTGGCAAGCTAGAGTATGGTAGAGGGTAGTGGAATTTCTGTGTAGCGGTGAAATGCGTAGATATAGGAAGGACACCAGTGGC
+
::[email protected]@[email protected]<;;9;[email protected]@[email protected]>@[email protected]@CEB?BCC>CBAA<@[email protected]@[email protected][email protected]@>@BBCBBBBBB?BB?B?AA<;AA=>=8>>>?8?>>989197//)/;+//7?=BB9>?A>E<?<??:>>@;;5;???;;;[email protected][email protected]>[email protected]@BAAC??<[email protected]@@[email protected][email protected]@@<?;5:>[email protected]@AAA<AAAC=??AA=A>[email protected]>>>7==;;;3;>==>AAABB=>=:=B3;:<?<[email protected]<>>4888888)8::)818A;93:<[email protected]?/:[email protected]>9992989*9<<8>B<@AAABAA;:;B=>>>888*8>@;;8;;?D6;;??<===9929999+9878899<[email protected]=7=7>,//6869;??<@
@47OC4:03984:00166
CTTGACACCGCGATTCCTCCGCTTATTGATATGCTTAAGTTCAGCGGGTAGTCCTACCTGATTTGAGGTCAAAGTTTGAAGATATACGTGGTAGACGTTACCGCCGCAAGCAATGTTTTTGGTTAGACCTAAGCCATTGTCAAAGCGATCCCGCCTTACCACTACCGTCTTTCAAGCAAACCCAAGTCGTATTGCTCAACACCAAACCCAGCGGTTTGAGGGAGAAACGACGCTCAAACAGGCATGCCTCCGGAATACCAGAGGGCGCAATGTGCGTTCAAAGATTCGATGATTCACGAATATCTGCAATTCATATTACGTATCGCATTTCGCTGCGTCTTCATCGATGCGAAAACCAAGAGCATTCCGTTGTTGAAGTTTTGACTATTAAGTAATAA
+
99:[email protected]=::49558>?:[email protected]::;5;5:<5::9444)4:8885:8849::><044:54455)5<<1:<8695:;;A999>@><0///27:55615=>266=<[email protected]@G+;7>;9955.5949=8A<?BB?AA<@BCCCCG<@@[email protected]@[email protected]:99A;[email protected]@@@@::48=;>?=?>=199,[email protected]@992,5<,59A?9>;;<3<<78335444(9>>:;000-(-5(-(/(/694;:555-7;77175//////588(527-56;;<[email protected]@>[email protected]?C>:99?>399A???>[email protected]=<;;;;;;;::<?000=<0099999*920)/7////)/3--(-53/-(-666&--6//36;63//1///
@47OC4:03984:00173
TCTAACGGACGATTCCTACGGGAGGCAGCAGTGGGGAATATTGCACAATGGGCGCAAGCCTGATGCAGCCATGCCGCGTGTATGAAGAAGGCCTCGGGTTGTAAAGTACTTTCAGCGGGGAGGAAGGGGTGAAGATGTAATAACCTTTGGCCAGATTGAAGGTTACCCCGCAGGAAAGAACAACCGGG
+
AABC:@[email protected]@A:;2:=BBBBB=AA>@IECCCCBCB8A?AAC?AB:[email protected]:99;88,33<88<>;;5;97808==A>?877=16/6;16(/.35.5057=A9A79797.7;=:;<<3:7;<4889(-,,,2,,***(**(*(*2',(,0-,**,,,(*(*(((((#((*,(**'*4(..(.(.(.
@47OC4:03984:00179
TCGCAATTACGATGGACTACCAGGGTATCTAATCCTGTTCGATACCCGCACTTTCGAGCTTCAGCGTCAGTTGCGCTCCAGTGAGCTGCCTTCGCAATCGGAGTTCTTCGTGATATCTAAGCATTTCACCGCTACACCACGAATTCCGCCACTTGTGCGTACTCAAGGAAACCAGTTCGCGCTGACAGTTCAGATGTTGAGCATCTACATTTCACAACACGCTTAATCTCCGGCTACGCTCCTTAACCCAACTAAATCGAATCGATACGCCCCGGGACCTTCCGTATTAACGCGGCTGCTGGCACGGAATTAGCCGGTCCTATTCATAAGGTACAGTGCAAAAAATGTCTCTACGAGCACATCGAACCATTTTATTCCCCTTTAATTCAAAAATTGAGAACAGCTTAA
+
[email protected];CCBBDCACCCCC>;;;)4<>?AB?BA?ACA?A?BBBCC>[email protected]@<@@[email protected]@A>>>>>AA<@@@???>[email protected]?<@[email protected]?BBC????<[email protected]?BBBA???;[email protected]@>>7>>>:>????AA;@@@A:@9=98839//*/9999?<;<[email protected][email protected];??>;<6///=9=4==///[email protected]??>>>[email protected]:@@;;8;[email protected];616*//;;6:6//8?>=>>5;4:088)819967-2222),(((((())55)22'*,,2,2(--22(-(---9(.-6...044..-.490522(,(,,(,-5,33=;39;;<9855555;;;;%3/.-22,,,,2,,,33244405(....&.92777&,,',(((()555()))222(,,226,22

Hello Newton,

Maybe it’s Phred64 incoded instead of Phred33. You could try passing this option to see if that enables the import:
–source-format SingleEndFastqManifestPhred64

Let me know how well that works for you,
Colin

Hi @newton!

You are specifying a source format of SingleEndFastqManifestPhred33 - so you should import the manifest file, not a single FASTQ file. Please take a look at our importing guide - all the answers you seek are awaiting you there!*

Thanks! :t_rex:

*Okay, maybe not all, but still, this is a good start!

Thank you for the prompt response.
I understand the manifest file format. However, all my data is in one file. The manifest file defines one file per sample. I have a file with barcodes-vs-samples. I am pretty sure that is not going to work out.
Are my options in this case are:
(a) re-export data per sample and create a manifest file?
(b) there is a way to split samples after I get this one file in for all samples?

Thank you

1 Like

I have tried that. That is not working either.

What does this mean? Can you please provide a sample of this file?

If your reads are already demultiplexed somewhere, then this would be a pretty easy way to get going.

This process is called “demultiplexing,” and we have a few ways to accomplish that in QIIME 2. As I mentioned above though, if you already have your reads somewhere in a demultiplexed format, then you should just import those files. You can use the manifest format. If you don’t already have your reads demultiplexed, then we need a sample of what you are trying to import. Thanks.

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.