importing files as CasavaOneEight

I seem to be having trouble importing my data.
All my files are named with the same format
LDK8450_1A1_L001_R1_001.fastq.gz
LDK8450_1A1_L001_R2_001.fastq.gz
LDK8451_1A2_L001_R1_002.fastq.gz
LDK8451_1A2_L001_R2_002.fastq.gz
LDK8452_1A3_L001_R1_003.fastq.gz
LDK8452_1A3_L001_R2_003.fastq.gz
etc.
and keep receiving this error message

"There was a problem importing /dataset/FACE_soil_microbiome/itmp/MS211111-1408:

Unrecognized file (/dataset/FACE_soil_microbiome/itmp/MS211111-1408/LDK8547_6B2_L001_R2_098.fastq.gz) for CasavaOneEightSingleLanePerSampleDirFmt."

Although I can't seem to find any difference in file type or name format.
I have tried removing this particular file and the same error appears for another file.
I have 108 samples (216 files R1 and R2) and so I'm not sure how many other files will have this error

@ms.Doyle,

Can you post the entire command that you are using to try to import?

qiime tools import
--type 'SampleData[PairedEndSequencesWithQuality]'
--input-path /dataset/FACE_soil_microbiome/itmp/Seq
--input-format CasavaOneEightSingleLanePerSampleDirFmt
--output-path VL_16S_PE.qza \

@ms.Doyle,

I believe you are running into this because your CASAVA file numbers are not 001, which is not a problem, do not go through and rename them :joy: It is just so strong a convention that we use it to validate the file names. You should be able to use a "manifest" import.

Your import command would look something like this:

qiime tools import \
  --type 'SampleData[PairedEndSequencesWithQuality]' \
  --input-path FACE_soil_manifest \
  --output-path paired-end-demux.qza \
  --input-format PairedEndFastqManifestPhred33V2
1 Like