Importing fastq.gz files into QIIME2 Galaxy


I have demultiplexed paired-end data in fastq.gz files for each pair-end read. They are in a folder called 16S. I tried importing the folder (16S which has all fastq.qz files) into Galaxy using Get data> Regular> Choose local files but I am getting an error message. Any feedback on how to import sequence data would be helpful.

I also tried using the URL did not work either.

Thank you

Hello @shaista_karim,

Welcome to the forums! :qiime2:

I also read your other post, and noticed that you were using the Qiime2 through Galaxy, deployed with Docker. I'm not super familiar with the Galaxy wrapper for Qiime2, and I'm wondering if there are some additional configuration and set-up steps required to get this Galaxy deployment working. This resource may be helpful: GitHub - qiime2/q2galaxy: Generate Galaxy tool descriptions automatically from QIIME 2 actions.

I wonder if it might be easier to get Qiime2 set up and running if you installed qiime natively. Most of the tutorials and guides are built for the native install, and this may be easier to debug compared to Galaxy + Docker + Qiime2.

See if you can get files imported with a native install of Qiime2, then we can work on getting Galaxy running, if you would like.

:qiime2: :whale: :milky_way:

Thank you @colinbrislawn
I successfully installed QIIME2 natively and was able to import "casava-18-paired-end-demultiplexed" and visualize the artifact using QIIME2 view.

However, when I tried to import my data using the same plugin- I generated the artifact but it shows an error when I am using qiime2 view to visualize it. Both code and .qza are attached.

Any feedback will be highly helpful. Thank you!

Uploading: demultiplexed-sequences.qza...

Thanks for posting that. I'm glad you are making progress with Qiime2!

What errors are you seeing when you try to use qiime2-view? Keep in mind that the .qza file is the Archive with your full data. If you run qiime demux summarize, as shown in this part of the Moving Pictures tutorial, you can make a qzv file with a Vizulation that might look better in qiime2-view

@colinbrislawn -----yay- it worked!

Thank you so much. you guys amazing!

@colinbrislawn Can we now try my original question to debug importing it into galaxy? Again, Thank you in advance.

The tutorials say to use " qiime2 tools import" (attached) but that tool does not exist in galaxy (attached).

I followed Running QIIME 2 inside Galaxy (alpha release version) - YouTube tutorial to install QIIME2 Galaxy.

Hi @shaista_karim!

(Nice to see you on the forum!)

It looks like this is my bad, the import tool is missing in the docker container. I will get that fixed and let you know how to proceed with updating it once it's ready. We're actually about to have another release, so if you are able to wait a few days, you can update to the latest version in a single step.

If you aren't in a huge rush, I might advise waiting until next week to update.

(I may also need to create a video on updating a docker container on Windows if it proves overly complex.)

Thank you so much- since you mentioned, you will be updating galaxy tool- I would also like to bring this up that in which ever tool we need to add metadata from artifact ("this option is currently missing in all tools in galaxy").

For example in workshop we did this couple of time (attached in the screenshot).

No problem, I am not in rush I am now using command line interface for my data analysis- once galaxy is all up and I can hop around.

Thank you so much the whole team is very helpful- I couldn't imagine doing all this without the tutorials and feedback from you'l.

1 Like

I can only speak for my self with very little background computing skills that I was only able to set everything up because of the video (especially the installations steps)- please consider posting one on updating docker if you have sometime..

Thank you!


That makes sense, the update to the latest QIIME 2 version should fix that as well!

Sounds good, I'll follow up here when the new version is available.

And in general, thank you for trying out this interface! It's really awesome to see people working with it.

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.