Importing data using Qiime studio


I am trying to import data using the studio application in Qiime2, I have also tried using command line from the tutorials, import help and suggestions from the forum. Thus far I have been stuck on this for 2 weeks.

The error I keep getting is:

BAD REQUEST - No transformation from <class ‘q2_types.per_sample_sequences._format.CasavaOneEightSingleLanePerSampleDirFmt’> to <class ‘qiime2.plugin.model.directory_format.QIIME1DemuxDirFmt’>

And variations of it depending on what I choose in the Source format.

My raw metagenome sequence files are in Fastq format from an ion torrent. They are already demultiplexed and the barcode removed and they are single end reads. So I tried everything suggested; GZ transformation Fastq manifest, CSV files I tried multiple options in Studio Source format and Semantic type.

My skills with command line are limited but I tried using that too more errors not recognising file type. I know the files work since I have run them through MG rast, megahit and ray.

The problem remains I don’t know how to upload the data.

Any help would be appreciated.


Hello @Walid!

Wow, that is a really long time! In the future I would recommend reaching out here on the forum much sooner, we can work together to try and figure out these kinds of problems!

Perfect - thanks for this info! Since your reads are already demultiplexed, I would check out the Fastq-manifest format - this will allow you to define a CSV file with entries for all of your Fastq files. Then, you point the import command at that manifest file and et voila - you should have imported, per-sample sequences when it is done.

If you get stuck, please attach your manifest file and we can diagnose from there. Thanks! :t_rex:

An off-topic reply has been split into a new topic: Mafft calledprocesserror

Please keep replies on-topic in the future.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.