Importing data Qiime2

Hello

As a beginner to Qiime2 and programming, I was all day trying to prepare and import my fastq.gz files to the qiime2 to start the analysis.
I have 79 samples. Pair-end reads (attached),
I am following The moving picture tutorial using mac terminal.
I am not sure how others import their data, but there might be an easy solution as well, but it was very time-consuming to me as beginner,
To import all my data at the same time, I made an excel file (manifest file), then copied and pasted the name of each sample ( R1.fastq.gz and R2.fastq.gz ) one by one for all the samples and then found the absolute path of each and copied and pasted in the excel file.

  1. What if there were more samples (like more than 100 samples) we should do it manually?

  2. After all these preparations, I got some errors. Sometimes it complains about the name of the samples in the manifest file (I double checked path and sample Id are the same) and sometimes about the headers.

I used:
qiime tools import --type 'SampleData[PairedEndSequencesWithQuality]' --input-path /Users/MQ44726791/alcl/manifest.csv --output-path paired-end-demux.qza
--input-format PairedEndFastqManifestPhred33
I followed all the importing tutorial section but couldn't fix my problem.

Thank you very much




1 Like

Hi!
Can you try to change in your manifest file
“sample-Id” on “sample-id”?

1 Like

In my case, I just created a directory, and copied all reads there using search option for “fastq.gz” in the file manager from uziped file with reads, and imported like this:

qiime tools import \
    --type 'SampleData[PairedEndSequencesWithQuality]' \
    --input-path raw_data/ \
    --input-format CasavaOneEightSingleLanePerSampleDirFmt \
    --output-path demux-paired-end.qza

Hello Dear Timanix

I did not know that lower or upper case matters, But It solved the problem,

Thank you

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.