Importing data - Manifest file not recognized

Hello everyone! I´m trying to get my already demultiplexed PE sequences imported to qiime2, using the manifest protocol and coming across some issues! If anyone could help me I appreciate!!
The error I am getting back is that the file manifest.txt (or .tsv) is not a PairedEndFastqManifestPhredd33V2 file because the first column (sample id) is not recognized despite bein specified in the input file:
This is the manifest file I´ve created:


and this is the error I´m getting back:

I appreciate any suggestions! have a nice day!

Vani

Hi @Vani_Maguire!

Your manifest file looks fine to me - the issue appears to be with your import command. You have a PairedEndFastqManifestPhred33V2 file, but you're telling QIIME 2 that it is a PairedEndFastqManifestPhred33 file in your import command (note that you're missing the V2 at the end of the word). You should be able to just append V2 to the end of the import format. Keep us posted!

:qiime2:

Hi!! thank you for your answer!! the code I´m running (I added the "V2" part) is this:

qiime tools import --type 'SampleData[PairedEndSequencesWithQuality]' --input-path manifest_16S --output-path paired-end-demux.qza --input-format PairedEndFastqManifestPhred33V2

but still getting back the same error! I can´t see where the error is!

Vani

Good news @Vani_Maguire, its actually a different error! This one is telling us that QIIME 2 was in fact able to load your manifest file. The issue is that there was a problem finding one of your fastq files specified in the manifest (the fwd reads for sample L1_10). Have you double-checked that that is the exact file name? And that that is the exact location of the file?

It´s right! it is a different error, but I checked and the sample name and location are ok. Here is a screenshot of the location of my sequences (fastq) and their names!

Indeed, I copied the exact names in order to create the manifest file! Is there something else I´m missing?

Vani

Thanks for sharing the screenshot! Yes, the filenames look okay to me, but the path (leading up to the filename) does not match between the screenshot and your manifest.

manifest:

$PWD/media/sf_qiime2/analisis_bac/16S/Trimm_PE/

screenshot:

/media/sf_qiime2/analisis_bac/16S/Trimm_PE/

Do you see this difference there at the beginning of the path? Your manifest has a variable at the beginning ($PWD) which means "print my current working directory". In this case, what that is expanding to is:

/media/sf_qiime2/analisis_bac/16S/Trimm_PE/media/sf_qiime2/analisis_bac/16S/Trimm_PE/

which is definitely not a real directory on your computer (which lines up with the error from QIIME 2, its telling us it can't find a file at that location).

I think if you remove the $PWD at the beginning of each path you should be set.

Keep us posted!

My God!!!! that actually worked!!!! thank you so much! I´ve been trying to solve this issue since Monday!

Great!!! thank you so much!
Have a nice day!
Vani

1 Like