Importing Data into QIIME2

Hi,

I am new to the QIIME2 program and at the step of importing data in the form of Casava 1.8 single-end demultiplexed fastq. I am using these commands:
qiime tools import
–type ‘SampleData[SequencesWithQuality]’
–input-path casava-18-single-end-demultiplexed
–input-format CasavaOneEightSingleLanePerSampleDirFmt
–output-path demux-single-end.qza

I have tried the example data provided as well but I would always receive this error:
(1/1) Invalid value for ‘–input-path’: Path ‘cassava-18-single-end-demultiplexed’ does not exist.

Does anyone know how to troubleshoot this? Thanks.

Welcome to the forum!
It’s looks like you are providing a wrong path to the folder, containing sequences you want to import.

Just replace ‘cassava-18-single-end-demultiplexed’ with the path or name of directory in which you store sequences.
Hope this helps.
Best

Thanks for getting back to me. I am currently using the example data given under the importing data tab in QIIME2. So shouldn’t the path or name of directory be ‘cassava-18-single-end-demultiplexed’ as well? I’m still quite confused about this.

Hi @Jan
Could you provide a screen of ls command in your working directory? It may help to resolve the issue.

I've tried using the example data and it works fine. So I tried using my own data this time round and received these error. Not quite sure what went wrong. Could you help me with this? Thanks.

Screen Shot 2021-04-15 at 9.28.09 am

Screen Shot 2021-04-15 at 9.33.38 am

Screen Shot 2021-04-15 at 11.25.59 am

Hi @Jan :wave:
Thank you for providing screenshots.
As I can see, you indicated a folder with fastq files as an input, and provided a SingleEndFastqManifestPhred33V2 at the same time. So, the plugin is expecting a manifest file, which should contain paths to fastq files.
Could you try to replace SingleEndFastqManifestPhred33V2 with CasavaOneEightSingleLanePerSampleDirFmt in your command?

qiime tools import \
  --type 'SampleData[SequencesWithQuality]' \
  --input-path 28_weeks_gut_microbiome_raw_sequences_J0545_Luisa \
  --input-format CasavaOneEightSingleLanePerSampleDirFmt \
  --output-path demux-single-end.qza

I tried my best to type your directory name without an errors but please double check it.

1 Like

Hi @timanix , thanks! I managed to import my files into QIIME2. Right now I am currently at the sequence quality control step and because my data was already given to me demultiplexed, I do not have the summary of the demultiplexing results. Which allows me to determine how many sequences were obtained per sample, and also to get a summary of the distribution of sequence qualities at each position in your sequence data.

I have tried the last few commands of the demultiplexed section:
qiime demux summarize
–i-data demux.qza
–o-visualization demux.qzv

But I received an error message that says:
There was a problem with the command:
(1/1) Invalid value for ‘–i-data’: ‘demux.qza’ is not a valid filepath

Do you know how I can go about trouble shooting this error? Thanks again.

Hi @Jan ,

Plugin is complaining that there is no file named ‘demux.qza’ in your working directory. You need to provide an exact name or path to the output you indicated when you imported reads in previous command.
For example, if you used command I provided above, the input should be:

Hi @timanix , thanks for this, it was extremely helpful! I managed to get the summary of the demultiplexing results. Another quick question because received this error message after the sequence quality control step using DADA2. Must I already have a metadata file to do this step?

Screen Shot 2021-04-21 at 10.12.06 am

Hello!
This time plugin is complaining that you do not have a file ‘sample-metadata.tsv’ in your directory. So, if you already have a correctly formatted metadata, you can indicate it instead, or just remove this parameter since it is an optional part.

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.