Importing data - Casava 1.8

Hi everyone, hope you are doing fine,

I’m totally new on QIIME2 and I’m trying to import my raw data and I already had some issues.

My data is from the Illumina MiSeq and I believe it’s already demultiplexed, since I only have 2 fastq files per sample (i.e: 19_S19_L001_R1_001.fastq and 19_S19_L001_R2_001.fastq).

This is what I’ve being doing:

(qiime2-2018.8) [email protected]:~$ mkdir sf_qiime2_shared_folder

(qiime2-2018.8) [email protected]:~$ cd sf_qiime2_shared_folder

(qiime2-2018.8) [email protected]:~/sf_qiime2_shared_folder$ qiime tools import \

> --type ‘SampleData[PairedEndSequencesWithQuality]’ \

> --input-path casava \

> --input-format CasavaOneEightSingleLanePerSampleDirFmt \

> --output-path demux-paired-end.qza

I created the shared folder “ qiime2_shared_folder ” and defined it as my directory, and tried to import the folder “casava” (which contains the fastq files for the analysis), however I get the message:

Error: Invalid value for "–input-path": Path "casava" does not exist

And when I give the command ls sf_qiime2_shared_folder , I get the error message:

ls: cannot access ‘sf_qiime2_shared_folder’: No such file or directory

I think I misunderstood the directory function and cannot define it properly (causing the problem to import the files). I believe it’s a very simple step, since it’s the first one, so I’m sorry for the basic question, but if anyone could help me, I would be really grateful.

Thanks in advance!

Hi @Cravo_Adri,

Where is the casava directory located? Is it within your qiime2_shared_folder, or somewhere else? If it’s not in the same folder, you’ll need to give the full path.

Best,
Justine

P.S. You can list the directories in your current folder with the command, ls.

Hi @jwdebelius, thanks for the feedback.
The casava folder is inside the shared folder Screenshot%20from%202018-12-10%2014-29-54|556x500 . I tried to define the shared folder again as my directory, but I get the message: mkdir: cannot create directory ‘sf_qiime2_shared_folder’: File exists
I also tried mkdir qiime2_shared_folder and it accepted the directory, however when I try to visualize it, I get the messsage ls: cannot access ‘qiime2_shared_folder’: No such file or directory

Thanks again!

Hi @Cravo_Adri, looks like something went wrong with your screenshot, can you please try again?


sorry, I deleted the first letter by accident

Hi @Cravo_Adri,

Thanks for the screen shot.

Could you try the command, PWD, to make sure you’re in the directory where you want to be working? You can also list the contents of your current directory with either ls or ls ..

Best,
Justine

Hi @jwdebelius, I tried the command pwd and it actually gave me a light about what was wrong. I didn’t write the complete path to the folder, so I couldn’t work in the directory I wanted. Now this problem is solved!
Thank you and @thermokarst for the feedbacks :slight_smile:

2 Likes

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.