Importing and merging multiplexed files

Hello,

I’m handling someone else project and have 9 different single-end multiplexed fastq files (actually 3 samples with 3 repeats each).
I have a metadata file- how can I import those 9 files into one qiime2 artifact file without losing the identity of each file, so I can continue with the qiime2 pipeline? I’ve tried the Casava 18 method, but since my original 9 files are not zipped it seems not to work.
This is the code I’m trying:

(qiime2-2017.10) [email protected][banana] qiime tools import \ [ 5:11PM]
–type ‘SampleData[SequencesWithQuality]’
–input-path “/home/eddie/Barak/banana/eddie_single_end/”
–source-format CasavaOneEightSingleLanePerSampleDirFmt
–output-path demux-single-end.qza

Thank you for your help.

Hi @barakdror,

So that I’m 100% clear on this, you have already demultiplexed your reads in that each file contains reads that belong only to that sample? And in your case you have 3 sources with 3 samples each for a total of 9 sampling events?

If that’s the case, then you should be able to use a fastq manifest file to import. You’ll want SingleEndFastqManifestPhred33 as your particular --source-format. This will detect if your files are gzipped and gzip them on the way into the artifact if they aren’t already.

Another option is to gzip your files assuming they match the expected filenames for CasavaOneEightSingleLanePerSampleDirFmt.

If I’ve misunderstood, could you provide a screenshot of the files you are trying to import so I can get a better sense of how they are named/related? Thanks!

1 Like

Hi @ebolyen,

Thans you for the answer.
Yes- I do have 9 demultipexed files (in fasta format, not zipped) of the experiment- 3 sources with 3 samples each, for a total of 9 samples.

I’ll try the fastq manifest file method, hope it will work. I thought about using add.qiime.labels that will make me one fasta file out of the 9 files but will still keep the sampleID- but it seems not to work on qiime2.

Hi,

I did tried the fastq manifest-
I uploaded all the fastq files to the directory (set as WD) with their names as written in the manifest.txt file (attached).
I ran this code, but it still not working:
manifest.txt (587 Bytes)

(qiime2-2017.10) [email protected][eddie_single_end] qiime tools import \ [ 1:19PM]
--type 'SampleData[SequencesWithQuality]'
--input-path manifest.txt
--output-path single-end-demux.qza
--source-format SingleEndFastqManifestPhred33

There was a problem importing manifest.txt:

manifest.txt is not a(n) SingleEndFastqManifestPhred33 file

Hey @barakdror,

You are just missing the header line. Make sure the first line says this:

sample-id,absolute-filepath,direction

Otherwise the rest of your file looks good to me! Try adding that line and running the import command again.

Thanks!

It worked. Many thanks!

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.