Importing a demultiplexed raw reads

Hi everyone,

Thanks for your previous insights on installation which I finally figured out. A few questions:

i. My raw sequences have arrived and for each sample, I have a folder with forward and reverse reads (.fastq) files. Does that mean my sequences are already demultiplexed?

ii. I am trying to import a single forward read for practicing with the downstream analysis but the following error code appears.

(Susan16s) susanpyakurel@SusanPyakurel:~$ qiime tools import \

--type 'SampleData[PairedEndSequencesWithQuality]'
--input-path /mnt/c/190.fastq
--output-path demux.qza
--input-format CasavaOneEightSingleLanePerSampleDirFmt
qiime: command not found

I am using Windows and Ubuntu WSL. The sequence is stored immediately inside C: as 190.fastq. I have made sure qiime2 is installed properly. Why do you think this is happening?

Your insights are appreciated. Thank you.

Yes! You can import them using the fastq manifest format.

You have activated the conda environment called Susan16s. There should be a conda environment that starts with "qiime2-" that has Qiime2 installed inside of it. Try activating that one.

Sometimes it works best to move files into the WSL Linux home directory, instead of using the root C drive. That's not causing the current problem, but we can try moving the files if that's helpful.


Thank you for your previous suggestion. Here is the new issue. Does this list of packages that include qiime2 mean qiime2 is already installed? If so, why might there be this error? Thanks again; appreciated.

Ah, I have found the problem. Qiime2 is in your conda environment, but it does not work when you run it.

Try following the install guide here. This will set up a new conda environment that hopefully will work.

1 Like

Thank you. But in vain; at this point, I'm just starting to feel hopeless. I did as the QIIME2 tutorial suggested. It just keeps on saying that it can not solve the environment.

Instead of this update command, I also checked whether wget command was installed or not and since it was there, I proceeded to installing QIIME2 in the current conda environment via WSL as mentioned in the native installation guidelines. It just keeps saying 'solving environment' thing.

The steps that I took when I did stuff in the beginning after conda was installed are:
Installing the channels

conda config --add channels conda-forge

conda config --add channels bioconda

conda config --add channels qiime2/label/r2022.8

conda config --set channel_priority strict

Creation of conda environment

conda create -n qiime2-2022.8 qiime2


conda activate qiime2-2022.8

Installation of QIIME2

conda install -c qiime2 -c bioconda -c conda-forge qiime2

Installation of QIIME2 dependencies

conda install wget


conda env update --name qiime2-2022.8 --file qiime2-2022.8-py36-linux-conda.yml

rm qiime2-2022.8-py36-linux-conda.yml

The (base) then changes to qiime2-env but it still says the qiime command is not valid.

So the conda update conda worked but it found potential conflicts. However, it still ended up running completely. After this, I ran the wget installation (conda install wget) followed by

conda env create -n qiime2-2023.2 --file qiime2-2023.2-py38-linux-conda.yml

conda activate qiime2-2023.2

(I even tried squeezing in conda install -c qiime2 -c bioconda -c conda-forge qiime2 here alternatively)

qiime --help

After which the same old 'qiime command not found appeared'.

I see there are some incompatibilities but I'm not sure how to get my head around them/understand their implications in a bigger picture.

Good morning,

I really appreciate your persistence in solving this problem. Thank you for trying all these things to get conda working.

Here are some things to try next:

  • Use a fresh install of miniconda with Python 3
    If your conda is broken, that could explain all other issues.
  • qiime2-2022.8 vs 2023.2 use the newest version of Qiime2
  • Update conda channels. We have new advice! Try this instead:
conda config --add channels defaults
conda config --add channels bioconda
conda config --add channels conda-forge
conda config --set channel_priority flexible

I think a new miniconda install or correct channel order will fix this issue! :+1:

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.