import paired end file using qiime2-2019.4 and cutadpat error

Dear Friends,
I am runing qiime 2019.4 version

I followed these steps:

qiime tools import --type 'SampleData[PairedEndSequencesWithQuality]' --input-path manifest_file_1to11-paired-end-DNA.csv --output-path ww-DNA_1to11_paired-end-demux.qza --input-format PairedEndFastqManifestPhred33

qiime cutadapt demux-paired --i-seqs ww-DNA_1to11_paired-end-demux.qza --m-forward-barcodes-file DNA_1to11_metadat-forward.tsv --m-forward-barcodes-column FPrimerSequence --m-reverse-barcodes-file DNA_1to11_metadat-reverse.tsv --m-reverse-barcodes-column RPrimerSequence --p-error-rate 0 --p-batch-size 0 --o-per-sample-sequences ww-DNA_1to11_paired-end-demux-trimmed.qza --o-untrimmed-sequences ww-DNA_1to11_paired-end-demux-untrimmed.qza --verbose

After cutadpat step I get this error:
(1/1) Invalid value for "--i-seqs": Expected an artifact of at least type
MultiplexedPairedEndBarcodeInSequence. An artifact of type
SampleData[PairedEndSequencesWithQuality] was provided.

Please let me know what is the issue here?

For cutadpat, I made two metadata file, one for forward primer and other for reverse primer. One thing to mention is that both forward and reverse primer are in both R1 and R2 fastq files. In this scenario, how to run cutadapt step? and how to make metadata file with both primers in one file for all samples? Attached are the metdata files. Could you please let me know if it is correct and if not can you please suggest how to make one with both primers in both forward and reverse file.

Thanks!DNA_1to11_metadat-forward.tsv (2.7 KB)
DNA_1to11_metadat-reverse.tsv (2.7 KB)

Sorry! My bad, I was using wrong parameter "demux-paired" where I should be using "trim-paired". It works now :slight_smile:


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.