import data into qiime

HI.
How to import demultiplexed files into qiime using command line.

Hello @komal, have you looked at the QIIME 2 importing tutorial found here? It has instructions on importing various types of data. Please review it if you haven't yet, and if you still need help let me know.

1 Like

I did and following the same.
However, I keep getting new errors. following is one

qiime2) temp@temp-B365M-DS3H:~$ qiime tools import
--type SampleData[SequencesWithQuality]
--input-path /home/temp/Desktop/manifest.tsv
--output-path home/temp/Desktop/paired-end-demux.qza
--input-format PairedEndFastqManifestPhred33
Usage: qiime tools import [OPTIONS]

Import data to create a new QIIME 2 Artifact. See https://docs.qiime2.org/
for usage examples and details on the file types and associated semantic
types that can be imported.

Options:
--type TEXT The semantic type of the artifact that will be
created upon importing. Use --show-importable-types
to see what importable semantic types are available
in the current deployment. [required]
--input-path PATH Path to file or directory that should be imported.
[required]
--output-path ARTIFACT Path where output artifact should be written.
[required]
--input-format TEXT The format of the data to be imported. If not
provided, data must be in the format expected by the
semantic type provided via --type.
--show-importable-types Show the semantic types that can be supplied to
--type to import data into an artifact.
--show-importable-formats
Show formats that can be supplied to --input-format
to import data into an artifact.
--help Show this message and exit.

                There was a problem with the command:                     

(1/1) Got unexpected extra argument (PairedEndFastqManifestPhred33)

When you split a command across multiple lines on the command line, you need \ at the end of each line but the last. Like so:

qiime tools import \
--type SampleData[SequencesWithQuality] \
--input-path /home/temp/Desktop/manifest.tsv \ 
--output-path home/temp/Desktop/paired-end-demux.qza \
--input-format PairedEndFastqManifestPhred33

This isn't a QIIME 2 thing; it's a thing that the terminal requires.

Additionally, is your data single-end or paired-end? I ask because the type you specified is SampleData[SequencesWithQuality] which is a single-end type, but the format you specified is PairedEndFastqManifestPhred33 which is a paired-end format.

If your data is single-end, you should change the format to SingleEndFastqManifestPhred33 and leave the type as is. If your data is paired-end you should change the type to SampleData[PairedEndSequencesWithQuality] and leave the format as is.

2 Likes

Hello oddant1
Thank you for your time.
I did try what you suggested. I am still getting a error.

(qiime2-2022.2) temp@temp-B365M-DS3H:~$ qiime tools import \ --type SampleData[PairedEndSequencesWithQuality] \ --input-path /home/temp/Desktop/manifest.tsv \ --output-path home/temp/Desktop/paired-end-demux.qza \ --input-format PairedEndFastqManifestPhred33
Usage: qiime tools import [OPTIONS]

Import data to create a new QIIME 2 Artifact. See https://docs.qiime2.org/
for usage examples and details on the file types and associated semantic
types that can be imported.

Options:
--type TEXT The semantic type of the artifact that will be
created upon importing. Use --show-importable-types
to see what importable semantic types are available
in the current deployment. [required]
--input-path PATH Path to file or directory that should be imported.
[required]
--output-path ARTIFACT Path where output artifact should be written.
[required]
--input-format TEXT The format of the data to be imported. If not
provided, data must be in the format expected by the
semantic type provided via --type.
--show-importable-types Show the semantic types that can be supplied to
--type to import data into an artifact.
--show-importable-formats
Show formats that can be supplied to --input-format
to import data into an artifact.
--help Show this message and exit.

              There were some problems with the command:                  

(1/4) Missing option '--type'.
(2/4) Missing option '--input-path'.
(3/4) Missing option '--output-path'.
(4/4) Got unexpected extra arguments ( --type
SampleData[PairedEndSequencesWithQuality] --input-path
/home/temp/Desktop/manifest.tsv --output-path home/temp/Desktop/paired-end-
demux.qza --input-format PairedEndFastqManifestPhred33)

P.S. My data is paired end.

Hello @komal. The slashes are only necessary if you are splitting your command across multiple lines. If you are keeping your command on one line you do not need them.

Examples of what I mean in terminal:


image



It looks like you used slashes in the middle of a command that you did not split across multiple lines.

Ok. I applied the suggested changes. I get the followin error.
(qiime2) temp@temp-B365M-DS3H:~$ qiime tools import --type SampleData[PairedEndSequencesWithQuality] --input-path /home/temp/Desktop/manifest.tsv --input-format PairedEndFastqManifestPhred33 --output-path /home/temp/Desktop/paired-end-demux.qza
There was a problem importing /home/temp/Desktop/manifest.tsv:

/home/temp/Desktop/manifest.tsv is not a(n) PairedEndFastqManifestPhred33 file:

Found header on line 1 with the following labels: ['sample-id\tabsolute-filepath\tdirection'], expected: ['sample-id', 'absolute-filepath', 'direction']

I did try changing the input formats to phred33V2 and even 64. still the same error. as follow. I have attached the mansifest file snap.

/home/temp/Desktop/manifest.tsv is not a(n) PairedEndFastqManifestPhred33V2 file:

'forward-absolute-filepath' is not a column in the metadata. Available columns: 'absolute-filepath', 'direction'

image

P.S. Thank you for your time and paitence. I just started working on microbiome data.

Use PairedEndFastqManifestPhred33V2 and modify your manifest like so for all entries:


image


You are currently labeling the forward and reverse reads as though they were separate samples, but they are the forward and reverse reads for the same sample. It looks like you already have sample IDs that are C10, C11, and so forth and the R1 files are forward and the R2 files are reverse.

Does that make sense?

1 Like

Dear @Oddant1
It worked!!! Finally imported the data
Thank you so much for your time and paitence.

2 Likes

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.