Import data errors

hello,

I am new ti qiime2, but have successfully used the program about 2 weeks ago with our issue. I now have some new data, and I cannot input it.

I get this error

There was a problem importing casava-18-paired-end-demultiplexed:

casava-18-paired-end-demultiplexed/._SB-01_S128_L001_R1_001.fastq.gz is not a(n) FastqGzFormat file:

File is uncompressed

I have not seen this error previously, these are what my files look like

11%20AM

I am suing qiime2 2017.12, can anyone help??

Hi @swillyb,

To help with the trouble-shooting, could you also provide the exact command you are using to produce the error please.

Hi @swillyb!

In addition to the command, I noticed something interesting about your filename:

It starts with a dot which means it is “hidden” by default. It’s probably a leftover from a text editor. Would you be able to run ls -alh in your directory? If I’m right, you’ll see both ._SB-01 and SB-01 in there.

Hi! Thanks so much for the reply!!
I just got this figured out!
It was weird, they weren’t being recognized at real .gz files so I ran gunzip *.gz to unzip them all into just fastq and then gunzipped them all back to .gz. Thjos worked in terms of import.
Im not sure how it will affect the data downstream? if at all?

I ran the ls -alh in the directory and there aren’t any ._ at the start fo the file name.

S

That is kind of weird.

The only risk is that you have incomplete fastq files. Usually gzip breaks in a different way so its more obvious, but if you want to be safe, double check the contents via something like md5sum with the originals (or retrieve the originals again and use those).

Well that’s good I suppose!

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.