Ignore_missing_samples argument emperor


(Stef) #1

Hi,
Any updates on the ignore_missing_samples argument for core_diversity? It´s driving me crazy to have to select my samples manually :frowning_face:
Keep up the good work!
/Stef


(Matthew Ryan Dillon) #2

That flag was added to the visualizers in q2-emperor in the 2018.11 release! :qiime2: :t_rex:


(Stef) #3

Thanks! Sounds awesome! Just updated to qiime2-2018.11 in conda and tried:

qiime diversity core-metrics-phylogenetic --i-table filtered-table_f4s3.qza --i-phylogeny fasttree_rooted.qza --p-sampling-depth 9272 --m-metadata-file short_meta_full_names.txt --p-n-jobs 2 --output-dir core_div_phylo_9272/ --verbose --p-ignore-missing-samples
Usage: qiime diversity core-metrics-phylogenetic [OPTIONS]
Try “qiime diversity core-metrics-phylogenetic --help” for help.

Error: no such option: --p-ignore-missing-samples
Can you see what´s wrong?
Thanks again!
Stef


(Nicholas Bokulich) #4

(Matthew Ryan Dillon) #5

Hey @Stef!

Yep! I wasn’t as clear as I should’ve been in my initial reply:

The ignore_missing_samples flag have been added to:

The param can be used by directly running one of those q2-emperor commands directly. That parameter has not been exposed in the diversity core-metrics or diversity core-metrics-phylogenetic pipelines, and I don’t think we are currently planning on making that change, since it is so specific to q2-emperor. If you want to take advantage of that new parameter, you can run the constituent commands on their own, remembering to supply the ignore_missing_samples flag as appropriate. Since you are asking about emperor specifically, you can skip all of the alpha steps and skip straight to the beta metrics.

:qiime2: :t_rex:


(Matthew Ryan Dillon) #6

(Nicholas Bokulich) #7

See the flowchart here for a list of the constituent commands.