IDs missing when viewing alpha-rarefaction curves in QIIME2 view.

Hello

I’m running QIIME2 (q2cli version 2021.4.0). The command I’m running is:

qiime diversity alpha-rarefaction
–i-table 16s_table_filtered.qza
–i-phylogeny 16s_rooted_tree.qza
–p-max-depth 9062
–m-metadata-file metadata.tsv
–o-visualization 16s_alpha_rarefaction.qzv
–verbose

My metadata file (which has been verified by keemei) looks like this:
metadata.tsv (929 Bytes)

The command is successful, but when I view it in QIIME2 view online, under the drop down menu “Sample Metadata Column”, it doesn’t give the option to select and view it by sample ID. I can get around it by adding a duplicate column of the ID names (with a different header) though this seems redundant to have to add in the same info.

I notice the same thing happens when viewing the alpha-rarefaction.qzv file in the Moving Pictures tutorial: “Moving Pictures” tutorial — QIIME 2 2021.4.0 documentation - the .

Is this to be expected or is it an issue with how I’m running things?

Many thanks
Gayle

@gkphilip,

This is the expected behavior. The alpha-rarefaction visualizer works by generating multiple rarefied tables at each sampling depth between 1 and the --p-max-depth and then returning an average diversity value for all of the tables generated for a particular depth of rarefaction.

The plot produced relies on having multiple samples per group, which would not be the case if it tried to plot individual samples. You might be interested in checking out the Parkinson’s Mouse Tutorial or this video on our channel for a bit more of an in-depth discussion of the topic.

1 Like

Hi Keegan

Thanks for your reply. I’m still a little confused so I think I may have not explained my issue clearly in my first post though.
I’ve attached a screenshot of my issue on QIIME2 view with some notes added to it.

This metadata file is the one with the duplicate columns (ID and Code are the same).
metadata_duplicateCol.tsv (1.0 KB)

The metadata file with the duplicate column gives the output I’m hoping for as shown in this screen shot:

Basically, my issue is that I would like to look at my rarefaction curves in terms of the sample IDs which I cannot get as an option.

I’m happy to provide more info if you need it.

Thanks in advance,
Gayle

Ahhh I understand what you’re saying now!

Sorry for my confusion.

@gkphilip no problem, glad you have it now!