I installed QIIME2 on a VirtualBox for Windows, at first it worked, but today it doesn't start and says symbol gruc_calloc not found, what happened and what could I do? Note: QIIME 1.9.1 works for some reason.

Hello @alexmtt89, this appears to be a Linux related issue that cropped up just a few days ago with the latest release of GRUB 2 (some refs 1, 2). Your QIIME 1.9.1 VM probably uses an older unaffected version of GRUB. Your QIIME 2 VM must be using the latest broken version. There doesn’t seem to be a fix for this right now, but recreateing the VM may give you an older, working version of GRUB.

Some background, GRUB is the bootloader used by Linux. It’s what initially transfers control of your system to the Linux Kernel. Without it Linux can’t boot. grub_calloc most likely has something to do with memory allocation. It seems like the latest update either removed grub_calloc but left some attempts to use it in the code somewhere, or added a new attempt to use it before it’s available.

EDIT: After some more poking around there may be a way to rescue your current VM if you need to, but it’s probably a fairly involved process. If you can get away with just recreating it that will probably be much easier.

4 Likes

Hello Oddant1 and thanks for your answer. Since I’m a noob and I’m still learning, I feared that I messed up something, e.g. some conflicts.
I’ve just removed the QIIME2 image and installed it again from the original downloaded file, so now it works fine. But I fear that tomorrow I might get the same issue again. I guess that if I avoid updates it’s better?

Yeah if you avoid updating GRUB until a new version of GRUB is released that resolves the issue you shouldn’t have any more trouble with it.

2 Likes