I cant save the files in the container on my PC

Hey, I tried to do the moving pictures tutorial and save the files locally on my PC to upload them later to the qiime viewer website. I m using the newest Docker version and qiime2/core:2023.7. Whenever i try to save one of the documents from the container locally i get an error message "spawn docker ENOENT" - error of no entry. How do i fix this problem? Should i use the copy command in powershell instead of the one in Docker?

Hello @Soranity, to clarify, are you saying that you are running a QIIME 2 2023.7 Docker container on Windows and would like to copy the files you are producing in the Docker container out of Docker and onto your Windows system?

If so, what command are you using to do this? I believe the way it is typically done is with this command run inside of the Docker container.


Yeah this is what I want to do.
I choose the file in Docker, select save and choose a suitable output directory. However, the doc doesn't show up and I get the error message in Docker.

Have you tried using this command, docker cp?

1 Like

I will try it today as i m totally new to coding, it might take some time. I will mark the answer as a solution if it works

cp docker 4efdda59ccb42a59bc10391ff66aa8846aad3a99e25ba1049ef8b9b254746f70:/data/qiime2-moving-pictures-tutorial/demux.qza C:\Users\vg1u23\Downloads

i tried it but it did not work. this error code shows up.
Copy-Item : A positional parameter cannot be found that accepts argument 'C:\Users\vg1u23\Downloads'.
At line:1 char:1

  • cp docker 4efdda59ccb42a59bc10391ff66aa8846aad3a99e25ba1049ef8b9b2547 ...
  •   + CategoryInfo          : InvalidArgument: (:) [Copy-Item], ParameterBindingException
      + FullyQualifiedErrorId : PositionalParameterNotFound,Microsoft.PowerShell.Commands.CopyItemCommand

Hello @Soranity, the command is docker cp <name-of-your-container>:path-inside-your-container destination-path. It looks like you did cp docker, other than that I think your command is valid.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.