I am failed to install qiime2 on windows 10 using ubuntu

I have tried to install qiime2 using ubuntu and anaconda many many times , in ubuntu it gives me following problem everytime I tried to do it

whereas when I tried anaconda it says wget does not found even when I try to instal wget using commands I failed

Welcome to the forum, @sadaffaheem.
In the future, please remove the template copy when you post - it makes it harder for us to find your question within the topic. I took care of it for you here.

You’ve got a few different questions here, but have only provided details for one of them. I’ll try to help with that, and we’ll explore other options as needed. It looks like your computer is able to connect to data.qiime2.org

but not to raw.github.usercontent.com

I searched the forum :mag: for “connection refused”, and found many helpful results. This is often the result of institutional or national firewalls. Try navigating to the github URL with your browser to download directly. If that doesn’t work, contact your network administrator. They may be able to help you connect.

Let us know how it goes!

1 Like

some friend helped me to download it directly but even that one does not worked, I do not know why. can it be due to network as I am doing it in a university in
China

Github is frequently a target of China’s “great firewall”, and may be blocked by local networks as well, so that doesn’t surprise me. If you’d care to share the error messages you got while trying to install from the file your friend shared, maybe we can troubleshoot?

ok, let me share the error with that file , as I do not know who to share so I am copy pasting all

(base) [email protected]:~$ conda env create -n qiime2-2021.4 --file qiime2-2021.4-py38-linux-conda.yml

>>>>>>>>>>>>>>>>>>>>>> ERROR REPORT <<<<<<<<<<<<<<<<<<<<<<

Traceback (most recent call last):
  File "/home/sadaffaheem/anaconda3/lib/python3.8/site-packages/conda/exceptions.py", line 1079, in __call__
    return func(*args, **kwargs)
  File "/home/sadaffaheem/anaconda3/lib/python3.8/site-packages/conda_env/cli/main.py", line 80, in do_call
    exit_code = getattr(module, func_name)(args, parser)
  File "/home/sadaffaheem/anaconda3/lib/python3.8/site-packages/conda_env/cli/main_create.py", line 81, in execute
    spec = specs.detect(name=name, filename=get_filename(args.file), directory=os.getcwd())
  File "/home/sadaffaheem/anaconda3/lib/python3.8/site-packages/conda_env/specs/__init__.py", line 43, in detect
    if spec.can_handle():
  File "/home/sadaffaheem/anaconda3/lib/python3.8/site-packages/conda_env/specs/yaml_file.py", line 18, in can_handle
    self._environment = env.from_file(self.filename)
  File "/home/sadaffaheem/anaconda3/lib/python3.8/site-packages/conda_env/env.py", line 159, in from_file
    with open(filename, 'rb') as fp:
PermissionError: [Errno 13] Permission denied: '/home/sadaffaheem/qiime2-2021.4-py38-linux-conda.yml'

$ /home/sadaffaheem/anaconda3/bin/conda-env create -n qiime2-2021.4 --file qiime2-2021.4-py38-linux-conda.yml

environment variables:
CIO_TEST=
CONDA_AUTO_UPDATE_CONDA=false
CONDA_DEFAULT_ENV=base
CONDA_EXE=/home/sadaffaheem/anaconda3/bin/conda
CONDA_PREFIX=/home/sadaffaheem/anaconda3
CONDA_PROMPT_MODIFIER=(base)
CONDA_PYTHON_EXE=/home/sadaffaheem/anaconda3/bin/python
CONDA_ROOT=/home/sadaffaheem/anaconda3
CONDA_SHLVL=1
CURL_CA_BUNDLE=
PATH=/home/sadaffaheem/anaconda3/bin:/home/sadaffaheem/anaconda3/bin:/home/
sadaffaheem/anaconda3/condabin:/usr/local/sbin:/usr/local/bin:/usr/sbi
n:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/mnt/c/Program Files
/WindowsApps/CanonicalGroupLimited.Ubuntu20.04onWindows_2004.2021.222.
0_x64__79rhkp1fndgsc:/mnt/c/Python/Python395/Scripts:/mnt/c/Python/Pyt
hon395:/mnt/c/WINDOWS/system32:/mnt/c/WINDOWS:/mnt/c/WINDOWS/System32/
Wbem:/mnt/c/WINDOWS/System32/WindowsPowerShell/v1.0:/mnt/c/WINDOWS/Sys
tem32/OpenSSH:/mnt/c/Program Files (x86)/IVI
Foundation/VISA/WinNT/Bin:/mnt/c/Program Files/IVI
Foundation/VISA/Win64/Bin:/mnt/c/Program Files (x86)/IVI Foundation/VI
SA/WinNT/Bin:/mnt/c/Users/admin/AppData/Local/Microsoft/WindowsApps:/m
nt/c/Program Files/Bandizip:/snap/bin
REQUESTS_CA_BUNDLE=
SSL_CERT_FILE=

 active environment : base
active env location : /home/sadaffaheem/anaconda3
        shell level : 1
   user config file : /home/sadaffaheem/.condarc

populated config files :
conda version : 4.10.1
conda-build version : 3.21.4
python version : 3.8.8.final.0
virtual packages : __linux=4.4.0=0
__glibc=2.31=0
__unix=0=0
__archspec=1=x86_64
base environment : /home/sadaffaheem/anaconda3 (writable)
conda av data dir : /home/sadaffaheem/anaconda3/etc/conda
conda av metadata url : https://repo.anaconda.com/pkgs/main
channel URLs : https://repo.anaconda.com/pkgs/main/linux-64
https://repo.anaconda.com/pkgs/main/noarch
https://repo.anaconda.com/pkgs/r/linux-64
https://repo.anaconda.com/pkgs/r/noarch
package cache : /home/sadaffaheem/anaconda3/pkgs
/home/sadaffaheem/.conda/pkgs
envs directories : /home/sadaffaheem/anaconda3/envs
/home/sadaffaheem/.conda/envs
platform : linux-64
user-agent : conda/4.10.1 requests/2.25.1 CPython/3.8.8 Linux/4.4.0-19041-Microsoft ubuntu/20.04.2 glibc/2.31
UID:GID : 1000:1000
netrc file : None
offline mode : False

An unexpected error has occurred. Conda has prepared the above report.

If submitted, this report will be used by core maintainers to improve
future releases of conda.
Would you like conda to send this report to the core maintainers?

[y/N]:

A few questions:

  • Is this ubuntu instance installed on your windows machine using WSL2?
  • Related, do you have root access, or is this instance administered by someone else?
  • If you navigate to /home/sadafffaheem/ and then run ls -lah, what do the permissions look like for qiime2-2021.4-py38-linux-conda.yml?

for anaconda prompt, it gives this error

(base) C:\WINDOWS\system32>conda env create -n qiime2-2021.4 --file qiime2-2021.4-py38-linux-conda.yml

SpecNotFound: Invalid name, try the format: user/package


(base) C:\WINDOWS\system32>anaconda-navigator
'anaconda-navigator' is not recognized as an internal or external command,
operable program or batch file.

(base) C:\WINDOWS\system32>anaconda navigator
'anaconda' is not recognized as an internal or external command,
operable program or batch file.

(base) C:\WINDOWS\system32>conda install -y wget
Collecting package metadata (current_repodata.json): done
Solving environment: failed with initial frozen solve. Retrying with flexible solve.
Collecting package metadata (repodata.json): done
Solving environment: failed with initial frozen solve. Retrying with flexible solve.

PackagesNotFoundError: The following packages are not available from current channels:

  - wget

Current channels:

  - https://mirrors.tuna.tsinghua.edu.cn/anaconda/pkgs/free/win-64
  - https://mirrors.tuna.tsinghua.edu.cn/anaconda/pkgs/free/noarch
  - https://repo.anaconda.com/pkgs/main/win-64
  - https://repo.anaconda.com/pkgs/main/noarch
  - https://repo.anaconda.com/pkgs/r/win-64
  - https://repo.anaconda.com/pkgs/r/noarch
  - https://repo.anaconda.com/pkgs/msys2/win-64
  - https://repo.anaconda.com/pkgs/msys2/noarch

To search for alternate channels that may provide the conda package you're
looking for, navigate to

    https://anaconda.org

and use the search bar at the top of the page.
  1. I also have ubuntu installed as shown by a video on youtube by some person who showed to install it

  2. I think it is not root access, it is university administration controlling it


  3. this appears on ubuntu after command, and is not working on anaconda prompt

Please use triple-backticks to display copy-pasted code as code blocks - it makes it much clearer what’s going on. I’ve edited the post above for you as an example.

  1. The error message you shared is probably occurring because you are trying to install QIIME 2 directly in windows. You’ll need to run those conda commands from within Ubuntu.
  2. You can probably fix the permission denied error by fixing the file permissions for the qiime2-2021.4-py38-linux-conda.yml file.

The r w and x characters on the left side of this guy tell you who has read, write, and execute access to those files.

image

It’s unusual to see --------, because it means nobody has permission to do anything with that file. I suspect this might be a WSL2/Linux thing.

Try navigating back to the directory in which you ran the ls command, and running chmod 744 qiime2-2021.4-py38-linux-conda.yml. Re-run the ls -lah command to confirm the permissions for that file are no longer --------, and then try creating the environment again with conda. Let us know how it goes.

I’d strongly encourage you to spend some time reading up on how unix-like systems work. That may sound imposing at first, but there are tons of good tutorials out there. This one does a nice job covering file permissions, and will give you clearer picture of what the notation and commands above mean.

2 Likes

wowwwwwwwwwwwww, it worked for me, after 3 weeks at last I did it, thank you so much for your time and support, I am really very very thankful. you resolved a big problem for me

1 Like