How to solve SEPP error

Hi everyone, I am new to qiime2.
When I ran qiime fragment-insertion sepp today with the practice in qiime2.org(https://docs.qiime2.org/2020.2/tutorials/pd-mice/),I have a error:Plugin error from fragment-insertion:
Command ‘[‘run-sepp.sh’, ‘/tmp/qiime2-archive-oon6jd9x/38472bfe-efb1-4470-804c-4fdde2b52e73/data/dna-sequences.fasta’, ‘q2-fragment-insertion’, ‘-x’, ‘4’, ‘-A’, ‘1000’, ‘-P’, ‘5000’, ‘-a’, ‘/tmp/qiime2-archive-smlxcngi/a14c6180-506b-4ecb-bacb-9cb30bc3044b/data/aligned-dna-sequences.fasta’, ‘-t’, ‘/tmp/qiime2-archive-smlxcngi/a14c6180-506b-4ecb-bacb-9cb30bc3044b/data/tree.nwk’, ‘-r’, ‘/tmp/qiime2-archive-smlxcngi/a14c6180-506b-4ecb-bacb-9cb30bc3044b/data/raxml-info.txt’]’ returned non-zero exit status 1.
Debug info has been saved to /tmp/qiime2-q2cli-err-n9q5qexs.log.
I want to know how to solve it.Thank you for all your assistance.

1 Like

Good morning!

Welcome to the Qiime 2 forums! :qiime2:

Can you post the log file /tmp/qiime2-q2cli-err-n9q5qexs.log and any other log files you can find? That should include more information about what went wrong.

Colin

Good morning @11125,

You could also try rerunning this command with the --p-debug flag to get additional information about SEPP and the error.

Let me know what you find!

Colin

Thank you very much for your help.

yeah, I can do it.
That’s I cat /tmp/qiime2-q2cli-err-n9q5qexs.log.
Removing /tmp/tmp.4rQPQQLCPg/sepp-tmp-jiPZkraIjD
Traceback (most recent call last):
File “/home/bob/anaconda3/envs/qiime2/lib/python3.6/site-packages/q2cli/commands.py”, line 328, in call
results = action(**arguments)
File “</home/bob/anaconda3/envs/qiime2/lib/python3.6/site-packages/decorator.py:decorator-gen-299>”, line 2, in sepp
File “/home/bob/anaconda3/envs/qiime2/lib/python3.6/site-packages/qiime2/sdk/action.py”, line 240, in bound_callable
output_types, provenance)
File “/home/bob/anaconda3/envs/qiime2/lib/python3.6/site-packages/qiime2/sdk/action.py”, line 383, in callable_executor
output_views = self._callable(**view_args)
File “/home/bob/anaconda3/envs/qiime2/lib/python3.6/site-packages/q2_fragment_insertion/_insertion.py”, line 77, in sepp
debug)
File “/home/bob/anaconda3/envs/qiime2/lib/python3.6/site-packages/q2_fragment_insertion/_insertion.py”, line 53, in _run
subprocess.run(cmd, check=True, cwd=cwd)
File “/home/bob/anaconda3/envs/qiime2/lib/python3.6/subprocess.py”, line 418, in run
output=stdout, stderr=stderr)
subprocess.CalledProcessError: Command ‘[‘run-sepp.sh’, ‘/tmp/qiime2-archive-oon6jd9x/38472bfe-efb1-4470-804c-4fdde2b52e73/data/dna-sequences.fasta’, ‘q2-fragment-insertion’, ‘-x’, ‘4’, ‘-A’, ‘1000’, ‘-P’, ‘5000’, ‘-a’, ‘/tmp/qiime2-archive-smlxcngi/a14c6180-506b-4ecb-bacb-9cb30bc3044b/data/aligned-dna-sequences.fasta’, ‘-t’, ‘/tmp/qiime2-archive-smlxcngi/a14c6180-506b-4ecb-bacb-9cb30bc3044b/data/tree.nwk’, ‘-r’, ‘/tmp/qiime2-archive-smlxcngi/a14c6180-506b-4ecb-bacb-9cb30bc3044b/data/raxml-info.txt’]’ returned non-zero exit status 1.
The error be found when i run
qiime fragment-insertion sepp
–i-representative-sequences ./dada2_rep_set.qza
–i-reference-database sepp-refs-gg-13-8.qza
–o-tree ./tree.qza
–o-placements ./tree_placements.qza
–p-threads 4

Thanks for posting your command!

Could you run that command again and add the --p-debug flag? That will give us more information about this error

Colin

I try add the --p-debug flag.
So i run qiime fragment-insertion sepp
–i-representative-sequences ./dada2_rep_set.qza
–i-reference-database sepp-refs-gg-13-8.qza
–o-tree ./tree.qza
–o-placements ./tree_placements.qza
–p-threads 4
–p-debug
Here are the results
qiime fragment-insertion sepp \

–i-representative-sequences ./dada2_rep_set.qza
–i-reference-database sepp-refs-gg-13-8.qza
–o-tree ./tree.qza
–o-placements ./tree_placements.qza
–p-threads 4
–p-debug
Plugin error from fragment-insertion:

Command ‘[‘run-sepp.sh’, ‘/tmp/qiime2-archive-zjl_fg02/352a0e07-d11f-4b4e-8b7a-2cb6b8300544/data/dna-sequences.fasta’, ‘q2-fragment-insertion’, ‘-x’, ‘4’, ‘-A’, ‘1000’, ‘-P’, ‘5000’, ‘-a’, ‘/tmp/qiime2-archive-2arj_dzl/a14c6180-506b-4ecb-bacb-9cb30bc3044b/data/aligned-dna-sequences.fasta’, ‘-t’, ‘/tmp/qiime2-archive-2arj_dzl/a14c6180-506b-4ecb-bacb-9cb30bc3044b/data/tree.nwk’, ‘-r’, ‘/tmp/qiime2-archive-2arj_dzl/a14c6180-506b-4ecb-bacb-9cb30bc3044b/data/raxml-info.txt’, ‘-b’, ‘1’]’ returned non-zero exit status 1.

Debug info has been saved to /tmp/qiime2-q2cli-err-2f5vp1mm.log

I cat the log,but it’s too long that i can’t write it.
So i upload it .qiime2-q2cli-err-2f5vp1mm.txt (2.2 MB)

SEPP operates in three phases: 1) HMMs are constructed for sub-trees 2) HMMs are used to score fragment at every sub-tree. This is done for all input fragments. Once “best” positions are thus determined, 3) all fragments need to be actually merged into the reference tree via pplacer. Phases 1+2 can easily be parallelized and consume time and only a little memory. However, phase 3 is expensive, especially with regards to memory footprint and runs in only one thread.

From the error log, I know that pplacer fails with exit code -11 (I have no clue what this code stands for) but I guess your process ran out of memory.

How much memory is installed in your system? How many fragments of what sequence length do you aim to insert?

My first suggestion would be to a) execute fragment insertion with only the first 10 fragments of your input to see if the program can be run without errors on a small input b) reduce the number of threads to 1 to have a better core / memory ratio. c) try to monitor memory consumption via e.g. top or time.

Let me know if the issue persists!

1 Like

Hello, as I already reported in the issue tracker
most probably the error derives from the use of vsyscall from pplacer.
vsyscalls are disabled by default now in Linux kernels, to avoid this issue the solution we found was to enable vsyscall=emulate in kernel boot options.

1 Like