How to find out the absolute path of the data file based on WSL system

I am trying to import data using the manifest option and am having difficulties with the absolute file path. I have read similar posts and tried what they tried, but with no success.

I am running Qiime2 2019.10 on Windows Subsystem for Linux (WSL), installed via miniconda.

My fastq files are in a folder.

My manifest file is formatted like this:

And when I run this command:
(qiime2-2019.10) [email protected]:/mnt/d/Data$ qiime tools import --type SampleData[PairedEndSequencesWithQuality] --input-path test-manifest --output-path PairedEndDemux.qza --input-format PairedEndFastqManifestPhred33

There was a problem:
An unexpected error has occurred:

 >  All paths provided in manifest must be absolute but found relative path:      /mnt/d/data/RawData/test/FDMP20H000275-1a_L1_C1_1.fq.gz
> See above for debug info.

Any other ideas?

Hi @Matteo,

Check out this post, and others in that thread.



This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.