How do you turn a .biom into a .qza?

How do you turn a .biom into a .qza?

1 Like

Try this:
https://docs.qiime2.org/2019.1/tutorials/importing/?highlight=import#feature-table-data

Welcome to the forums, Jordan! :qiime2:
Colin

3 Likes

I thought I could use the following, but the input format fails.

qiime tools import \ --input-path feature-table-v210.biom \ --type ‘FeatureTable[Frequency]’ \ --input-format BIOMV210Format \ --output-path feature-table-2.qza

E.G.

(qiime2) Jordans-MacBook-Pro:~ jordankueneman$ qiime tools import --input-path /Users/jordankueneman/Desktop/Research/Captive_Wild_Amphiib_t_90/Merge_OTU_w_tax/A_Biom_pieces_copied/Rana_Pretsiosa_reference-hit.withtax.biom --type ‘FeatureTable[Frequency]’ --input-format BIOMV210Format -output-path /Users/jordankueneman/Desktop/Research/Captive_Wild_Amphiib_t_90/Merge_OTU_w_tax/A_Biom_pieces_copied/Rana_Pretsiosa_reference-hit.withtax.qza

Error: no such option: --input-format

I have tried both BIOMV100Format and BIOMV210Format

Also I have now tried changing --input-format to --source-format –

then I get Error: no such option: -o

Thanks for your advice.

what version of QIIME 2 are you running? It sounds like you may be running an older version (in which case type qiime tools import --help into your terminal to see the parameter names that should be used)

this looks like you could have typos in your command; e.g., I can see at least one typo in the command you posted (though this could just be how text gets auto-formatted on the forum; use triple backticks (```) before and after code blocks to show pre-formatted text):

Let us know if that helps you root out the error.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.