How do I know what kind of fastq files I have?

Hi everyone,
Thank you in advance for helping me with this VERY basic question... so I got some fastq data back from the core, and I want to learn how to use QIIME2 on my own. I'm looking at the demultiplex tutorial, and it says to run these lines:
qiime demux emp-single
--i-seqs emp-single-end-sequences.qza
--m-barcodes-file sample-metadata.tsv
--m-barcodes-column barcode-sequence
--o-per-sample-sequences demux.qza
--o-error-correction-details demux-details.qza

I did that, but I got a message that says "command not found." I'm wondering if I have the wrong type of files to start with? my files look like this 45%20PM

Could someone shed some light onto this? MANY thanks!

Hi @Rosekiki,

It’s not always super easy to know what kind of files you have, or how to get them in! (Or to figure out what to do with a new file type. Everyone’s situation is a little bit different.) It’s always worth checking in with a sequencing center the first time you work with them if you’re not sure. They can tell you exactly what they did. Plus, it never hurts to be on good terms with the people who do your sequencing.

That said, it looks like you have two files per sample (if E4B is a sample, KO-Sham1 is a sample and KO-Sham2 is a sample). My favorite format for per-sample importing is the manifest format. The pro is that I think it’s easier to trouble shoot if you run into problems. The con is that you have to build the manifest. But, your data might behave for the casava import.

Best,
Justine

2 Likes

thank you so much for your reply! I just emailed the place that did the sequencing for me to check.

Do you happen to know if the commands for creating these formats have changed at all due to the newer QIIME2 updates? I’m working off of the 2019.1 version.

Thank you in advance!

@Rosekiki, based on the error message you mentioned,

I’m wondering whether your conda environment is active when you’re running the demux command. If you installed QIIME 2 using miniconda, then you’ll need to activate the environment where you put QIIME 2 whenever you want access to QIIME 2 commands. The link above has instructions on how to confirm QIIME 2 is working.

Give activating your environment a try, confirm it’s working, and if that takes care of the command not found error, @jwdebelius’s link to the importing tutorial will probably get you the rest of the way.

If you don’t remember what your environment is called, you can use conda env list to get a list of environments on your machine.

All the best,
Chris

3 Likes

Commands do change, but you can generally trust the command line interface to tell you if you’ve misused a command somehow. Get familiar with the help flag (e.g. qiime demux emp-single --help), or use the docs that are relevant to your current version. It’s a little clunky to keep clicking “Show me the content on this page” so I usually stick with the help available through the CLI for non-current versions of QIIME 2.

That said, I would strongly recommend updating to the current version of QIIME 2. There have been a ton of awesome developments in the last seven months, including a refactor of q2-dada2 that has reduced my runtime on our HPC cluster from multiple days :turtle: to ~1 hour :rabbit2:.

Good luck!
Chris

3 Likes

ah yes, thank you for that reminder! What a newbie mistake I made there… I totally did NOT activate conda and qiime first! I just did that, and although I’m still running into problems, at least I get more informative error messages now!

2 Likes

Thank you Chris! I will get familiar with the help flag. Once I figured out this initial steps of how to input my fastq files, I’ll look into updating to the current version of QIIMe2. It looks like another version will be coming out soon!

2 Likes

Sound good. The installation process is usually pretty straightforward. We release every ~3 months, and the next release (2019.10) will roll out at the very end of October.
:slight_smile: CK

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.