Help ! ITS taxonomy

i got my illumina sequences data and i finifhed the importing data and denoising. however, when i began to training classifier, there was an error of source format of taxonomy txt. i download a classifier from forum, it didn’t work, there was still an error without massage. please help me…

hello, i wonder which source format you have used when you import the its taxonomy txt. it always show error, and i download classifier from Forum. however, when i run qiime feature-classifier classify-sklearn, it report error again. help me ~.~

Hi @zehua,
Sorry to hear you’ve been having a hard time! Have you seen this tutorial? That covers how to import taxonomy and sequence (fasta) files.

If this is a pre-trained classifier (does it have a .qza file extension?) then you do not need to import — it already is! If this is a classifier that someone else already trained, then you can go straight to the classification step, e.g., as shown here.

I hope that helps! If you are still having trouble I will need a little more detail: the actual errors you are receiving, the commands you are attempting to run, and the input files.

thank you for your help, Nicholas. i have learned that tutorial and i got success for training my 16S classifier. but i don’t know the source format that import for ITS. it is this step:
qiime tools import
–type ‘FeatureData[Taxonomy]’
–source-format HeaderlessTSVTaxonomyFormat
–input-path 85_otu_taxonomy.txt
–output-path ref-taxonomy.qza
the HeaderlessTSVTaxonomyFormat didn’t work for ITS sh_taxonomy_qiime_ver7_99_s_01.12.2017_dev.txt that i download from UNITE. so the first question is that i want to know which source format i should use to import the ITS taxonomy.txt
as for the classifier i download from the forum, it is a trained file(.qza file) however, it would appear error after 1hour when i run the
qiime feature-classifier classify-sklearn
–i-classifier classifier.qza
–i-reads rep-seqs.qza
–o-classification taxonomy.qza
i forget the massage, so i would do it again and copy the error for you. thanks.

how so? what error did you get? HeaderlessTSVTaxonomyFormat should be the correct format.

Again, you need to share the error to get actual support.

Though maybe you don’t need to share the error hear: based on your description I am almost certain that this is a memory error — your computer does not have enough RAM to use that classifier — and so it stops running once memory capacity is reached, after one hour. This error has been discussed extensively on the forum so look through those topics to get some advice on addressing this issue. You may simply need to get access to a more powerful machine.

The trained ITS classifier that you downloaded from the forum is identical to the one that you would have produced had you trained your own classifier on the ITS sequences, and so would have the same memory requirements. So my advice is to focus on solving the memory error, rather than attempting to address the importing error.

I hope that helps!

i changed the version of ubuntu, and the download classifier worked. so, i think it maybe the problem of ubuntu. as for the error, the terminal said that the file is not the format of HeaderlessTSVTaxonomyFormat. maybe also the problem of ubuntu? i will try it soon.
anyway, i got the result of sequences data after i change the version of ubuntu. and i will try in the new version to train my own classifier. thank you for your patient answer, thank you very much.

another question, my computer has 8g memory now, should i add it to 16g? it performed good when i run the 16S sequences data. and it is the first time that i see the error.

8 GB should be enough to run a UNITE ITS classifier; but if you are seeing that error then evidently you need to make some changes. See the link I provided above to search results on this forum: whether to upgrade memory or make other adjustments is all already discussed on those topics.

OK, i see. thank you again for solving my question.:kissing_smiling_eyes:

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.