Help installing an older (unsupported?) version of QIIME 2


I’m trying to install two versions of QIIME2 in parallel.
I have already installed QIIME2 2019.4 and It works properly.
Now I need an older version QIIME2 2019.1, so I have downloaded it and ran the following command:

conda env create -n qiime2-2019.1 --file qiime2-2019.1-py36-linux-conda.yml

But I got the following error:

Collecting package metadata: done
Solving environment: failed

UnsatisfiableError: The following specifications were found to be in conflict:

  • bioconductor-delayedarray=0.4.1
  • r-pillar=1.3.0

Use “conda search --info” to see the dependencies for each package.

Any suggestions?
Thanks in advance

Hi @mefistofele82,

This is a situation where conda-forge seems to move a little too fast for full reproducibility, which is very unfortunate. We don’t have a great solution ourselves to this, but what you could try is deleting those lines in the environment file. Conda will fill in the missing packages with versions that ideally exist (although it may be sufficiently broken that those are gone as well). You may have to do this a few times to end up with something that “works”.

That said, it will be an installation we haven’t tested, so we can’t promise anything about it. It wouldn’t be a bad idea to run the unit tests of the plugins you are interested in. This can generally be done via pytest (you’ll need to install that into the environment as well):

pytest --pyargs q2_feature_table

(q2-feature-table as an example, the plugins use underscores in their package names, rather than the dashes we prefer to use for the project names).

We work hard to ship the test data with the packages, so the tests should work if the dependencies aren’t too out of sorts.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.