Help in alpha/beta diversity. Error: no such option: --m-metadata-file

Hi, I keep getting an error that says my metadata file does not exist. This is the same file I used earlier as ‘sample metadata’ and it did work at that point. I am trying to work my data through the moving pictures tutorial, up until this point it has been working well but now I am a bit stuck… I have copied the commands I used below. Thank you for any help you might have!
(qiime2-2017.9) Kairis-MacBook-Pro:mwf_data_qiime_12_20_17 ruby$ qiime diversity core-metrics-phylogenetic \

–i-phylogeny rooted-tree.qza
–i-table table.qza
–p-sampling-depth 3464
–m-metadata-file 011817_mapfile_midwater_fishes.tsv
–output-dir core-metrics-results
Error: no such option: --m-metadata-file

Hi @ruby — that error message is actually saying that the command qiime diversity core-metrics-phylogenetic doesn’t have a --m-metadata-file option, not that it can’t find your metadata file. It looks like you are running QIIME 2 2017.9, but are referencing the docs for QIIME 2 2017.12. We added the option to provide metadata to this pipeline in 2017.10, which is why you are seeing this particular error.

You have two options - upgrade to QIIME 2 2017.12 (personally I would go with this option), or, use the dropdown on the docs site to pick 2017.9 as the version of the docs to reference. Hope that helps! :t_rex:

Hi!
I am so sorry to bother you…I had just figured that out because of another comment. I did not realize that when I regularly update conda it had nothing to do with qiime changes :frowning:
It is in the process now…Thank you for your help! (I am so new to all this!)
-Ruby

1 Like

Hi @ruby! No need to apologize, we are all here to help each other out :heart:. Good luck and happy QIIMEing! :t_rex:

All is working! Yay! Thank you again!

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.