Help! Creating a directory for a manifest


I'm running qiime2 on Ubuntu 20.04.6 and on anaconda3.

I'm trying to import data according to the tutorial that is available on qiime2. (Importing data — QIIME 2 2022.8.3 documentation). I'm working with PairedEndSequences and I've been using the following code.

qiime tools import
--type 'SampleData[PairedEndSequencesWithQuality]'
--input-path manifest2.txt
--output-path paired-end-demux.qza
--input-format PairedEndFastqManifestPhred33V2

However, I keep on receiving the following error. There was a problem importing manifest2.txt: manifest2.txt is not a(n) PairedEndFastqManifestPhred33V2 file: filepath on line 1 colum "forward-absolute-filepath" could not be found (\wsl.localhost\Ubuntu-20.04\home\diego\sequence-papers\seqs\SRR14771945_1.fastq) for sample "sample-1"

One of my classmates was able to run my code and data and they got the paired-end-demux.qza. I was wondering if I could get some help with setting up my directory, because that is where I am guessing the problem is coming from? I also think it is weird that it is saying it's not manifest2.txt is not a(n) PairedEndFastqManifestPhred33V2 file, because it worked for my classmate using the same code and data. I've also ran Phred64V2 and same error.

I've ran the the following as well with error: Problem importing manifest2.txt.. manifest2.txt is not a directory.
qiime tools import
--type 'SampleData[PairedEndSequencesWithQuality]'
--input-path manifest2.txt
--input-format CasavaOneEightSingleLanePerSampleDirFmt
--output-path demux-paired-end.qza

I'll attach the manifest files I've used as well where I got the fastq files.
fastq (ENA Browser)

I'm really lost! I'd greatly appreciate the help!

manifest.txt (5.6 KB)
manifest2.txt (5.5 KB)
test1.txt (539 Bytes)
test2.txt (359 Bytes)
test3.txt (455 Bytes)

Hi @RiparianForest,

Let's re-visist the core of the error message:

So, your filepath doesn't exist.

Im not a big WSL user, but one guess is that linux paths are formatted slightly differently. Try substituting the backslash () whcih is a windows path for a forward slash (/), which is a unix path.

You could also navigate to the direcotry where the files are kept in the terminal and using pwd to get directory as linux sees it.


Hey @jwdbelius,

I was actually able to figure out the filepath from another post from reddit. Thank you for you help! In case anyone was wondering. I replaced "\wsl.localhost\Ubuntu-20.04\home" with "$HOME/", and then replaced the backslashes "" with forward slashes "/"
It turned out like this: "$HOME/sequence-papers/seqs/SRR14771945_1.fastq.gz"


1 Like

Hi @RiparianForest,

I'm glad you were able to solve it! Thanks for sharing what you did for others.


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.