having trouble importing data


Please kindly assist, I am trying to use Qiime2 to convert a tsv table to a qzv/qza and I keep getting errors. I added a column to my metadata file in google sheets and i converted the table to a tsv file. now i want to convert the table to a qza/qzv file.

Hi @Priscillar_Wenyika,

Thanks for reaching out! Can you please provide us with more information? More specifically:

  • Is this a metadata file? If so, what are you trying to do with your metadata? Are you trying to run metadata tabulate? Or use it as a parameter in another command? Outside of metadata tabulate you cannot turn your metadata file into a QIIME 2 Artifact.
  • What error message(s) are you receiving?

This information will help us to better assist you. Thanks! :lizard:


yes, that's what i was trying to do. I have a metadata file in the qza format and i wanted to add an extra column to the table. i downloaded the table and made copied the information to a google sheet. i edited the google sheet and now i want to convert the google sheet to a qiiime qzv table

Hi @Priscillar_Wenyika,
You should be able to download your excel file as a .tsv and use that in qiime2.
Then you should be able to generate a .qzv by running this command: qiime metadata tabulate

Here is an example of this from our tutorial: Metadata in QIIME 2 — QIIME 2 2022.2.0 documentation

Hi @cherman2 let me try that, thank you

1 Like

[quote="cherman2, post:4, topic:26602"]
qiime metadata tabulate
i am getting an error message which says, 'qiime is not recognized as an internal or external command', operable program or batch file

Hi @Priscillar_Wenyika,
Make sure that you have your qiime env activated!

it seems like it is, but once i start to put in commands, then it gives that error message.

Hi @Priscillar_Wenyika,
That is weird! I would try uninstalling and reinstalling your qiime2 env. Looks like something got messed up in the qiime installation!

thanks, i will do that

1 Like

Hello @Priscillar_Wenyika,

You can't run qiime using windows. You can either install windows subsystem for linux, or use another computer that runs linux or macOS.


hello, thank you. i installed windows subsytem for linux and I have been installing qiime2 following the respective prompts for windows subsytem for linux. at some point if i ran qiime help/ info, I could see that qiime was installed but not anymore

Hi @Priscillar_Wenyika,
We need more information to be able to help! Could you please give us a step by step of what you are doing to activate your qiime2 env?
Could you also provide what error is occurring that is letting you know that qiime2 isn't installed?


1 Like

So firstly, i opened the command prompt (Miniconda 3), then i typed 'conda activate qiime2-2023.2'
when i do that, it then says 'qiime is not recognized as an internal or external command', operable program or batch file'
it also does the same when i type 'qiime --help'

Hello @Priscillar_Wenyika,

You are writing qiime2-2023.5 but the name of your environment is qiime2-2023.2.

This doesn't matter however, because as stated previously, you can not run qiime on windows. You said you installed windows subsystem for linux. Now you need to open a shell to that operating system and enter your commands there.


oh i see, thank you. let start everything all over again and see that goes

hello @colinvwood @cherman2 , i have been able to install qiime2 and i was able to create some folders and download the data for the importing data tutorial. I downloaded them to my root directly. However, I was wondering if you can help on how I can change directories or say view what's on my Desktop or what's in a certain folder on a Windows (WSL) . for example I ran this: (qiime2-2023.5) root@Priscillar:~# cd ~/Desktop
-bash: cd: /root/Desktop: No such file or directory

and I got the "no such file directory", I keep getting that error no matter how i change the command.

1 Like

Hello @Priscillar_Wenyika,

It looks like there may be some confusion about interacting with a linux command line. This book would be a good place to start.

Another piece of information that is going to help is that your windows file system is probably mounted at /mnt/c inside WSL.

1 Like

Here's something I do which I think you may find helpful:

When running WSL, you can run this command to open up the current Linux working directory in the Windows Explorer

explorer.exe .

Explanation: In Linux, the dot . means the current working directory.
So this command just tells the Windows File Explorer to open up your current folder.

I hope this helps! There's a lot to learn about Linux, but a little bit goes a long way.
We are happy to help you get started so you can use Qiime2. :qiime2:

1 Like

Thank you, i will give that a try