Generating multiple pcoA plots of the same size & downloading plots as SVG

Continuing the discussion from Rendering quality in emperor:

hi there @Nicholas_Bokulich and @yoshiki
when i try to save as SVG only the legend but no plot shows, is there something i am doing wrong? I am using qiime 2 view on chrome Version 65.0.3325.181 (Official Build) (64-bit) or Firefox Quantum 59.0.1 (64-bit)

Also, I would like to create a figure with multiple panels of pcoa plots, is there any way to save plot sizes so that i can generate multiple plots of the same size? I have tried using the save current settings option but I’m still getting plots of varying sizes - coloring and data category shape work, but plot size and shape sizes vary .
Thanks,
Nsa

my bad, nevermind! i just realized that save as SVG generates two separate files - one for the plot and the other for the legend…after updating to chrome Version 66.0.3359.117 (Official Build) (64-bit)…

i am still interested in learning how to generate multiple pcoA plots of the same size

1 Like

:point_up_2:t5::point_up_2:t5:

1 Like

@nerdynella, my guess is that you want to make different plots the same size, right? If this is the case, I don’t think this is possible or even easy to implement as all PCoAs have different shapes and sizes based on the spread of the spheres. Now, we normally make multi-panel images via an image editor: export all your images/panels as svg/png, open your favorite editor and arrange them to make your single, multiple panel image. Hope this helps.

I can reproduce this in Google Chrome, all seems to be working as expected in Firefox (did not try Firefox Quantum). For now, please use FireFox, in the meantime I will investigate and push get a patch in place as soon as possible.

If you are interested, I’ve opened a ticked in our tracker.

yeah, that’s what i’ve been doing so far - i thought that there was a way to standardize the plots just as we can with make_2d_plots.py in QIIME 1
Thanks for getting back.

Cheers,
Nsa

updating to Chrome Version 66.0.3359.117 (Official Build) (64-bit) resolved the issue. Thanks for looking into this @yoshiki

2 Likes

I can confirm that upgrading Chrome worked. Thanks @nerdynella!

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.