Fragment insertion SEPP issue

Hello everybody,

I have 4 16S datasets, 3 of these use region V4 and one another region, so I run the cmd:

qiime fragment-insertion sepp --i-representative-sequences 16S_repr_seq_deblur_merged_run.qza --o-tree 16S_insertion_tree.qza --o-placements 16S_rinsertion_placement.qza --p-threads 16 --verbose

And I get this errors a pile of errors of these nature: (line 532): INFO: Merging extension sto file (/media/nec3_HDD/Francesco/tmp/tmp.Aa2TqJRZnK/sepp-tempssd-sxeg/q2-fragment-insertion.9xptp35d/root/P_55/A_55_3/FC_55_3_3/hmmalign.results._qq_7bi0) into base alignment (/media/nec3_HDD/Francesco/tmp/tmp.Aa2TqJRZnK/sepp-tempssd-sxeg/q2-fragment-insertion.9xptp35d/root/P_55/A_55_3/hmmbuild.input.kzhvovca.fasta). (line 117): INFO: Finished pplacer Job with input: backbone_alignment_file:/media/nec3_HDD/Francesco/tmp/tmp.Aa2TqJRZnK/sepp-tempssd-sxeg/q2-fragment-insertion.9xptp35d/root/P_33/pplacer.backbone.ytqgdbx1.fasta, tree_file:/media/nec3_HDD/Francesco/tmp/tmp.Aa2TqJRZnK/sepp-tempssd-sxeg/q2-fragment-insertion.9xptp35d/root/P_33/pplacer.tree.40l9lt1m.tre, info_file:/media/nec3_HDD/miniconda3/envs/qiime2-2018.8/share/fragment-insertion//ref/, extended alignment:/media/nec3_HDD/Francesco/tmp/tmp.Aa2TqJRZnK/sepp-tempssd-sxeg/q2-fragment-insertion.9xptp35d/root/P_33/pplacer.extended.0.ce07e66a.fasta, output:/media/nec3_HDD/Francesco/tmp/tmp.Aa2TqJRZnK/sepp-tempssd-sxeg/q2-fragment-insertion.9xptp35d/root/P_33/pplacer.extended.0.ce07e66a.jplace

Thanks for your help!

If I run this cmd using only two datasets it works, one V4 dataset and the other V region.

Thanks for reporting @Fra! I am cc:ing @Stefan to take a look at this.

Hi Francesco,
would you mind mailing me your input data to [email protected] ?
The “errors” you pasted are only debugging information. I cannot see if it really is an error :-/
You could also run the same command with additional parameter in the hope to shed more light on this issue: --p-debug --verbose

H Stefan,

I actually run the command again and this time worked. However, at the end of the pipeline after checking the PCoA the 4 different runs still group by primer. Basically even though the script produced an output it did not do its work properly.

Do you have any clue?


Hi @Fra,

What metric did you use? It sounds like you have a batch effect at this point and if you used a quantitative metric in your PCoA that would only exacerbate the issue.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.