fragment-insertion error

Hello! First-time poster here so apologies if it isn’t in the right spot. I just tried to run qiime fragment-insertion sepp with the SILVA reference database built from this script. I’m doing a meta-analysis on about 2700 samples (all 16S) and figured fragment-insertion was my best bet at making a rooted tree after using SILVA 128 for closed reference OTU-picking on my merged tables and rep-seqs. I’m getting the following error:

Command ‘[‘run-sepp.sh’, ‘/tmp/qiime2-archive-_2kdjax0/c2fdd3b6-d86c-49d3-8401-e856f5576f08/data/dna-sequences.fasta’, ‘q2-fragment-insertion’, ‘-x’, ‘1’, ‘-A’, ‘1000’, ‘-P’, ‘5000’, ‘-a’, ‘/tmp/qiime2-archive-8g2mbjhe/1997c1a1-acf7-4f0a-a1cd-eec0efeb3ec0/data/aligned-dna-sequences.fasta’, ‘-t’, ‘/tmp/qiime2-archive-8g2mbjhe/1997c1a1-acf7-4f0a-a1cd-eec0efeb3ec0/data/tree.nwk’, ‘-r’, ‘/tmp/qiime2-archive-8g2mbjhe/1997c1a1-acf7-4f0a-a1cd-eec0efeb3ec0/data/raxml-info.txt’]’ returned non-zero exit status 1.

I know a few others had similar problems, but I wasn’t able to find a solution that worked - it doesn’t seem like space is an issue, although I could be wrong because of our behemoth dataset. I’m using 2019.10 on Ubuntu 18.04. Please let me know what additional information I should provide! Thank you so much for all you do and for such a well documented resource.

2 Likes

Good afternoon @kchhabria,

Welcome to the Qiime 2 forums! :qiime2:

I really appreciate your detailed post. There is a little more information that could be helpful. How large (MBs or GBs) is your input file? How much RAM / memory does your system have?

Could you also post the full command you ran and any log files you could find? I think that will give us enough clues to start looking for the issue! :female_detective: :female_detective:

Colin

2 Likes

A post was split to a new topic: fragment-insertion sepp error