Filter table based on taxonomy

I am trying to filter features based on taxonomy. I ran the following command, but got an error as pasted below. (Using qiime2-2021.11)

qiime taxa filter-table
--i-table table.qza
--i-taxonomy merged_taxonomy.qza
--p-exclude "d__Eukaryota;p__ABC;c__EFG;o__XYZ"
--p-mode contains
--o-filtered-table table.qza_NoXYZ.qza

Error msg:

Plugin error from taxa:
Detected metadata ID that begins with a pound sign (#): '#q2:types'
Debug info has been saved to /local/scratch/38835656.1.interactive/qiime2-q2cli-err-8somm8q0.log

Seems to me that the problem may be with the way metadata is formatted. But when I run the following command using the exact same files (table and taxonomy), it works fine: suggesting that the formatting is fine. So, not sure whats wrong.

qiime taxa barplot
--i-table table.qza
--i-taxonomy merged_taxonomy.qza
--m-metadata-file metadata.txt
--o-visualization taxa_barplots.qzv


Saved Visualization to: taxa_barplots.qzv

Does qiime taxa filter-table command uses a metadate file?



taxa filter-table doesn't use metadata. I specifically checked the code from the older version and couldn't find such an error. Please, attach your files, I'll try to reproduce.


Hi Valentyn,
Thank you for your response. I was able to figure out the problem while preparing the sample files to send to you. Thanks again.


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.