Files don't match after concatenation?

I used the cat function to combine three fastq.gz files into one big one, for both the R1 and R2 files (ie 3 R1 files were combined, and 3 R2 files were combined) before import. Then, when attempting to import them with:

qiime tools import
–type ‘SampleData[PairedEndSequencesWithQuality]’
–input-path ‘/scratch/msportie/uganda/16s’
–input-format CasavaOneEightSingleLanePerSampleDirFmt
–output-path demux-paired-end-16s.qza

Thiss error message was returned:

These samples do not have matching pairs of forward and reverse reads: {‘R1s’, ‘R2s’}

Is there a way to fix this problem? I’m on QIIME2 2019.7. I am not sure how it is installed, but I’m accessing it through a super computer cluster.

Thanks.

Hi @msport469,
Welcome to the forum!

It sounds like you already have demultiplexed files which are ready to be imported into Qiime2 using the manifest option. Combining them together prior is not necessary nor recommended. Is there a particular reason you are doing this?

3 Likes

@msport469 - @Mehrbod_Estaki raises some good points here. Also, are you combining files from different runs? If so, that could also be a problem for steps like DADA2 denoising, which operate on a per-run basis.

My question is: are the reads (before concatenating) multiplexed, or demultiplexed. Your command implies demuxed, but the concatenation suggests otherwise to me.

3 Likes

I have solved the problem. They were Casava 1.8 and didn’t need to be manifested in. Thanks for your time.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.