Files are there but it says there is no such a file.

I intended to merge two tables, but surprisingly it says there are not such files. I opened the terminal in the directory that the tables are there. I examined it a couple of times. Unbelievable! I shared the error with you to find out the problem. I used the three modes of --p-overlap-method parameter. The results are same.

qiime feature-table merge \

–i-data trimedtable.qza
–i-data trimedtable2.qza
–p-overlap-method sum
–o-merged-table mergedtables.qza
–verbose
Usage: qiime feature-table merge [OPTIONS]

Combines feature tables using the overlap_method provided.

Inputs:
–i-tables ARTIFACTS… List[FeatureTable[Frequency]]
The collection of feature tables to be merged.
[required]
Parameters:
–p-overlap-method TEXT Choices(‘error_on_overlapping_sample’,
‘error_on_overlapping_feature’, ‘sum’)
Method for handling overlapping ids.
[default: ‘error_on_overlapping_sample’]
Outputs:
–o-merged-table ARTIFACT FeatureTable[Frequency]
The resulting merged feature table. [required]
Miscellaneous:
–output-dir PATH Output unspecified results to a directory
–verbose / --quiet Display verbose output to stdout and/or stderr during
execution of this action. Or silence output if
execution is successful (silence is golden).
–examples Show usage examples and exit.
–citations Show citations and exit.
–help Show this message and exit.

              There were some problems with the command:                  

(1/2?) no such option: --i-data
** (2/2?) no such option: --i-data**

Thanks.
Qiimer

Hi @TurboQiimer
I suspect the error is saying ‘–i-data’ option does not exist, and should be replaced by ‘–i-tables’ as reported in the error!
Cheers

1 Like

Thanks @IIenzi
I mixed up with seq merging parameters.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.