Feature IDs don't match

Hi Matt,

This did not solve the issue.

My input was:
qiime taxa filter-table
–i-table [Table post-pairing, -QC, -deblur]
–i-taxonomy silva-132-99-taxonomy_NoSpaces.qza
–p-include 0__Bacteria
–p-mode contains
–output-dir [Table post-pairing, -QC, -deblur, -NoArchaea]

My output error was:
"Plugin error from taxa:

All features ids must be present in taxonomy, but the following feature ids are not:" and then many ID, like b47db366a25679dd507c550a23b82ace, 805a72c6085c867f05de73719aaf8870, 0367367b5700726abc795a11b382c763, b8ea2a4a5dae7de827152b8c21f643b1.


It did though!

This is a new error:

You need to use the taxonomy file that is created by running some form of feature classification. Otherwise, how can the table know anything about what taxon each feature is?

1 Like


Then run “qiime feature-classifier fit-classifier-naive-bayes” before “qiime feature-classifier classify-sklearn” and “qiime taxa filter-table”?


No, you don’t need to necessary train a new classifier - proceed to qiime feature-classifier classify-sklearn, then use the output from that (FeatureData[Taxonomy]) as the taxonomy input to qiime taxa filter-table.

Edit: I forgot that your original issue was related to labels in the taxonomy — yes, you will need to retrain, then reclassify, then you can filter.

Edited my post above.

Hi Matt,

I tried the potential solution (i.e., 1. qiime feature-classifier fit-classifier-naive-bayes; 2. qiime feature-classifier classify-sklearn; 3. qiime taxa filter-table) and the error is now at “qiime feature-classifier classify-sklearn.”

For qiime feature-classifier fit-classifier-naive-bayes [which worked], I did:
qiime feature-classifier fit-classifier-naive-bayes
–i-reference-reads silva-132-99-nb-otu.qza
–i-reference-taxonomy silva-132-99-taxonomy_NoSpaces.qza
–o-classifier silva-132-99-nb-classifier_NoSpaces.qza

For qiime feature-classifier classify-sklearn [which did not work], I did:
qiime feature-classifier classify-sklearn
–i-classifier silva-132-99-nb-classifier_NoSpaces.qza
–i-reads “Rep Seq file post pair, QC, and deblur”
–o-classification “Assign Taxa file post pair, QC, and deblur”

The error for the latter command was:
“Plugin error from feature-classifier:
pop from empty list”


Hi @Tyler_Carrier,
You must either not be using the SILVA 7-level taxonomy, or else you accidentally trimmed off some taxonomic data while removing terminal whitespace.

See here for a little more explanation of this error:

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.