extracting the reads silva version 138.1

Hi Qiimers

Never experienced problems when training the classifier , however I jeep on getting errors, I ran
qiime feature-classifier extract-reads
–i-sequences silva_138.1.qza
–p-f-primer gtgccagcmgccgcggtaa
–p-r-primer ggactachvgggtwtctaat
–p-trunc-len 120
–p-min-length 100
–p-max-length 400
–o-reads ref-seqs.qza

And the error I got:Plugin error from feature-classifier:

Invalid character in sequence: b’U’.
Valid characters: [‘M’, ‘Y’, ‘D’, ‘.’, ‘G’, ‘H’, ‘-’, ‘W’, ‘N’, ‘B’, ‘R’, ‘K’, ‘S’, ‘V’, ‘A’, ‘C’, ‘T’]
Note: Use lowercase if your sequence contains lowercase characters not in the sequence’s alphabet.

Debug info has been saved to /var/tmp/pbs.3040428.sched01/qiime2-q2cli-err-3dahgdpx.log
used both uppercase and lower case letters with no success and when I ran
tr ‘acgt’ ‘ACGT’ SILVA_138.1_LSUParc_tax_silva.fasta > reference-hit.seqs.uppercase.fa

I get an empty output, thanks in advance for your assistance

Hi @kedi!

Please check out this response from @SoilRotifer, regarding a very similar error message:

Hope that helps!

:qiime2:

2 Likes