Exporting .qza file from Qiime2 that is compatible with BugBase

Qiime 2 Version: 2022.2.1
ALL of the other plugins are 2022.2.

I am working on undergraduate research and need to use BugBase for Functional Annotation.
These are the BugBase requirements:

An OTU table is required to run BugBase. The OTU table should be:

  • In BIOM format (version 1.0, JSON)
  • Picked against the GreenGenes database (16S)*
  • Picked against IMG (shotgun metagenomic sequencing)*

What command lines would I run in qiiime2 in order to achieve the previously listed requirements for export from qiime2 and import into BugBase?


I used the following link for assistance:

but I still cannot seem to get it to work properly.

Hello Megan,

What have you tried and how well did it work?

Did you get the command qiime vsearch cluster-features-closed-reference to finish running properly?

I got every input command from the link to work properly, but when I input the file in .biom format to bugbase, it says that there is still an error with the format. Also, I know that those are example files, and I do not know when I should include my own file names into the input commands for it to use my files.

What did the error say? We need to inspect all the clues we can find! :mag:

These inputs

  --i-sequences rep-seqs-dada2.qza \
  --i-table table-dada2.qza \

should be your own output tables you got from running DADA2 on your real data.

Everything runs in Qiime2 just perfectly, however, when I upload the file into BugBase, it says: "There was an error while parsing your data. Please ensure your OTU and mapping files follow the format explained in the documentation. OTU tables must be the json version of biom."

I am wondering if the following link I am using doesn't have the output compatible with BugBase.

The BugBase requirements are:

An OTU table is required to run BugBase. The OTU table should be:

  • In BIOM format (version 1.0, JSON)
  • Picked against the GreenGenes database (16S)*
  • Picked against IMG (shotgun metagenomic sequencing)*
  • < 15 mb (web application only)

Let's check on this section

Then re-convert back to the older biom version we need.

biom convert -i feature-table-tax.txt -o feature-table-tax-biom1.biom

Can you run

head -c 50 feature-table-tax-biom1.biom

on your file from this step? We can check that it's in the BIOM v1.0 JSON format.

Other than that, it may be best to reach out to the BugBase folks and see what they think.

I also noticed this :thinking:

I've tested this with QIIME 2 version 2021.8, but this should work with any older version as well.

Maybe your newer version of Qiime2 does not work. Perhaps try Qiime 2021.8 :person_shrugging:

Thank you!

When I ran the
head -c 50 feature-table-tax-biom1.biom

after the mentioned step, the output was:
{"id": "None","format": "Biological Observation Ma

Now, my next question is: the website that I used for the input commands,

is it based on their examples? If so, when do I input my own data?

1 Like

Or, did it automatically use my data?

That website is not like a typical web app (gmail, youtube) where you interact with it and it processes and searches data on its servers.

That website is like a cooking tutorial, where they give you instructions on what to do, and you follow along with your own data on your own computer. It's very DIY.

In their example, they put in their example data at this step:

qiime vsearch cluster-features-closed-reference
  --i-sequences rep-seqs-dada2.qza \
  --i-table table-dada2.qza \

Now that you have got it working with their example data, replace these two inputs with your own data (that you got by running dada2).

Thank you tremendously for all of your time and help. It worked! I genuinely appreciate it.

Megan Whisonant

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.