Errors when running alpha-div


#1

Hello!
I am getting the same error mentioned in this thread when I try to run any of the alpha diversity estimators (phylogenetic and non-phylogenetic). The table I am using is the feature table (.qza) output from dada2. I’ve been trying to troubleshoot for a few days now, but no success so far.
Other plugins that use the same table run OK (e.g. alpha-rarefaction).
Note that I only have one sample (hence, I only want alpha diversity, not beta), and I am not using a metadata table (which I understand is not strictly required when working with only one sample).
Any help will be greatly appreciated!
Thanks.


qiime diversity core-metrics-phylogenetic error
(Matthew Ryan Dillon) #2

Hi @dcampo - can you please provide the following information, in order for us to help you:

  • The version of QIIME 2 you are running
  • The exact command (or commands) you ran (copy and paste please)
  • The exact, complete error you observed (copy and paste the results when run with the --verbose flag
  • Please include any relevant data for recreating the error, if possible.

Thanks!


#3

I see you’ve moved my comment into a new thread.
FYI, I did not start a new topic, cause the error I am seeing is the same than Castle mentions above, so I thought it’d be helpful to post it here.
Please let me know if you still want to keep my post as a separate topic, and I will update my comment to include all the information.
THANKS!


qiime diversity core-metrics-phylogenetic error
(Matthew Ryan Dillon) #4

No problem — it is a lot easier for us to diagnose and help on a case-by-case basis. Also, there is a link now between the two topics, so it is the best of both worlds!


#5

Hi,

  • I am running qiime2-2018.11

  • My command line:
    qiime diversity alpha-phylogenetic
    –i-table /qiime_analysis/table_dada2.qza
    –i-phylogeny /qiime_analysis/rooted_tree.qza
    –p-metric faith_pd
    –o-alpha-diversity /qiime_analysis/faith_pd_vector.qza
    –verbose

  • The verbose output:
    Traceback (most recent call last):
    File “/auto/cmb-07/sn1/dcampo/bin/anaconda2/envs/qiime2-2018.11/lib/python3.5/site-packages/q2cli/commands.py”, line 274, in call
    results = action(**arguments)
    File “”, line 2, in alpha_phylogenetic
    File “/auto/cmb-07/sn1/dcampo/bin/anaconda2/envs/qiime2-2018.11/lib/python3.5/site-packages/qiime2/sdk/action.py”, line 231, in bound_callable
    output_types, provenance)
    File “/auto/cmb-07/sn1/dcampo/bin/anaconda2/envs/qiime2-2018.11/lib/python3.5/site-packages/qiime2/sdk/action.py”, line 390, in callable_executor
    spec.qiime_type, output_view, spec.view_type, prov)
    File “/auto/cmb-07/sn1/dcampo/bin/anaconda2/envs/qiime2-2018.11/lib/python3.5/site-packages/qiime2/sdk/result.py”, line 265, in _from_view
    result = transformation(view)
    File “/auto/cmb-07/sn1/dcampo/bin/anaconda2/envs/qiime2-2018.11/lib/python3.5/site-packages/qiime2/core/transform.py”, line 70, in transformation
    new_view = transformer(view)
    File “/auto/cmb-07/sn1/dcampo/bin/anaconda2/envs/qiime2-2018.11/lib/python3.5/site-packages/qiime2/core/transform.py”, line 223, in wrapped
    new_view.file.write_data(file_view, self._wrapped_view_type)
    File “/auto/cmb-07/sn1/dcampo/bin/anaconda2/envs/qiime2-2018.11/lib/python3.5/site-packages/qiime2/plugin/model/directory_format.py”, line 86, in write_data
    result = transformation(view)
    File “/auto/cmb-07/sn1/dcampo/bin/anaconda2/envs/qiime2-2018.11/lib/python3.5/site-packages/qiime2/core/transform.py”, line 68, in transformation
    self.validate(view)
    File “/auto/cmb-07/sn1/dcampo/bin/anaconda2/envs/qiime2-2018.11/lib/python3.5/site-packages/qiime2/core/transform.py”, line 143, in validate
    view.validate(‘min’)
    File “/auto/cmb-07/sn1/dcampo/bin/anaconda2/envs/qiime2-2018.11/lib/python3.5/site-packages/qiime2/plugin/model/file_format.py”, line 34, in validate
    % (self.path, self.class.name))
    qiime2.core.exceptions.ValidationError: /tmp/q2-AlphaDiversityFormat-d8xpufzr is not a(n) AlphaDiversityFormat file

Plugin error from diversity:

/tmp/q2-AlphaDiversityFormat-d8xpufzr is not a(n) AlphaDiversityFormat file

See above for debug info.

  • Information about the sample:
    This is a gut microbiome sample, sequenced in a MiSeq in 2x150 format. Please note, it is only one sample.
    Input files were fastq, and I selected “SampleData[PairedEndSequencesWithQuality]” as the data type. Then I ran “cutadapt trim-paired”, and “dada2 denoise-paired” to create the features table.
    I’ve also run “phylogeny align-to-tree-mafft-fasttree” and “feature-classifier classify-sklearn” (using the green genes database), and all the visualization plugins to visualize the results. Everything has run with no issues. It is just the alpha diversity estimators that are giving me problems.
    Please let me know if there’s any additional information you would need.

Thanks!


QIIME diversity core-metrics-phylogenetic error
(Chris Keefe) #6

(Matthew Ryan Dillon) #7

That is most likely the problem, but I am not 100% sure. Can you DM me a link to download /qiime_analysis/table_dada2.qza and /qiime_analysis/rooted_tree.qza, that way I can recreate and debug locally?


(Matthew Ryan Dillon) #8

#9

Sure. What’s your address?


(Matthew Ryan Dillon) #10

Just send me a DM (via the forum):

One way to do that is to click on my avatar, then “Message”:

52%20PM