Errors in the installing of PICRUSt2 under QIIME 2 2020.8 version

Hello everyone!
I would like to intall PICRUSt2 in the latest QIIME2 following the instruction of this website (https://github.com/picrust/picrust2/wiki/Installation#install-from-source). I had tried both from bioconda and source, and got different error messages. Here is the detail error information:

  1. from bioconda:
    run
    conda create -n picrust2 -c bioconda -c conda-forge picrust2=2.3.0_b
    in the Termial,

    after previous process, and then I got this error message:

    the final message just like this:

    However, it can’t work with picrust2 yet!
  2. from source:
    I download the package of picrust2-2.3.0-b and unzip it. And then
    cd picrust2-2.3.0-b/
    conda env create -f picrust2-env.yaml
    system inform me
    CondaValueError: prefix already exists: /home/qiime2/miniconda/envs/picrust2
    So I run
    conda activate picrust2
    pip install --editable

    However, when I run the pytest, I got these error messages:

Anyone could give me some suggestions, please! Thanks!

Best wishes

Long

@LXE_Soil_ecol, if you are flexible on which QIIME 2 version you use, installing q2-picrust2, should be easier. This plugin appears only to be supported for use with QIIME 2 2019.2 at this time.

If you need to run picrust2 with the latest version of QIIME 2, @gmdouglas can probably give you a better sense of what barriers stand in your way.

Best of luck! :rat:
Chris

Thanks, I would try installing picrust2 with qiime 2 2019.2 version.

1 Like