Error while importing: "invalid distance too far back"


I have a set of data I am trying to import to run QIIME2 on, and it keeps getting stuck at the importing step.

Below is what I have for the import command:
qiime tools import --type ‘SampleData[PairedEndSequencesWithQuality]’ --input-path MC72_Sequences --input-format CasavaOneEightSingleLanePerSampleDirFmt --output-path demux-paired-end.qza

I have used QIIME2 successfully before with the exact same command as above, but I cannot seem to get over this error message with my current dataset.

When I look at the log, it says: “zlib.error: Error -3 while decompressing data: invalid distance too far back
An unexpected error has occurred:Error -3 while decompressing data: invalid distance too far back”

I tried looking on this forum but I could not find how to figure this error out.

Any help would be appreciated!
Thank you.

Good morning @HinakoT,

That error means that the input file(s), the ones in the directory MC72_Sequences, have been corrupted when they were being copied or downloaded to that folder. Can you move them into that folder again, and see if that solves the problem?


1 Like

Hi Colin,

I did just that and now it works!

Thank you so much for the help.


1 Like