Error when runnin gneiss ols-regression

Hello,
First, I want to thank you for the development and the support! I’m really enjoying learning how to perform my analyses with qiime2.

Second, I have an issue with running gneiss ols-regression.
I performed the analysis with a rooted tree.
When I try to run the regression I receive the following error:
’the label [y7] is not in the [index]'
Can you please help me understand what is the problem?

Thank you,
Lena

Hi @LenaLapidot,
It sounds like maybe there is no y7 in your data.

Could you please share:

  1. the exact command that you are running
  2. the full error message?
  3. any artifacts you have that suggest that y7 should exist

Thanks!

It does sound like that, but I don’t have any indexes with this kind of name.

I used this command first:
(qiime2-2018.8) ➜ Merged experiments analysis qiime gneiss ilr-phylogenetic
–i-table filtered-table-PSC-Controls.qza
–i-tree rooted-tree.qza --output-dir core-metrics-results-gnesis
–o-balances balances.qza
Saved FeatureTable[Balance] to: balances.qza
Saved Hierarchy to: core-metrics-results-gnesis/hierarchy.qza

and then:
iime gneiss ols-regression
–p-formula DiagnosisGroup+FUT_Phenotype
–i-table balances.qza
–i-tree hierarchy.qza
–m-metadata-file Merged_metadata-PSC-Controls.tsv
–o-visualization regression_summary.qzv
Plugin error from gneiss:

‘the label [y7] is not in the [index]’

I tried then running the commands with correlation clustering and this error didn’t return…
However, I didn’t receive the taxa.qza file:

Merged experiments analysis qiime gneiss correlation-clustering
–i-table merged-table-PSC-HCC.qza
–o-clustering hierarchy.qza
Saved Hierarchy to: hierarchy.qza
(qiime2-2018.8) ➜ Merged experiments analysis qiime gneiss ilr-hierarchical
–i-table merged-table-PSC-HCC.qza
–i-tree hierarchy.qza
–o-balances balances.qza
Saved FeatureTable[Balance] to: balances.qza

So because I don’t have the taxa.qza I can’t run the balance taxonomy command…

Thank you for the help !

Hi @LenaLapidot could you share the files so that we can reproduce this error?

I’m getting the same error, 'the label [y13] is not in the [index]'

@LenaLapidot, I’d be interested see if @mortonjt can sort this out. Alternatively, I could provide the files I’m working with for trouble-shooting.

In case it’s relevant I’m working with the docker installation of Qiime 2018.8 and my balances were built on a subset of samples using a rooted tree generated from all samples in the experiment. Still, gneiss ilr-phylogenetic completed without an error.

It is possible that the ids are not matched between the internal nodes of the tree and the balances. @aphanotus, want to provide those files so that I can investigate? I just need the feature table, the balance table and the tree to confirm.

Sure. gneiss.files.zip (332.6 KB)

Hi @aphanotus and @LenaLapidot sorry about the delay. Found that problem is boiling down to the tree not being trimmed down the sequences contained in the table. Your tree has more sequences than the table, which is causing issues.

Just pushed in a PR here to fix this. The work around in the meantime is to manually trim those sequences via

import qiime2
from skbio import TreeNode
import pandas as pd
from gneiss.util import match_tips

table = qiime2.Artifact.load("<your-table>").view(pd.DataFrame)
tree = qiime2.Artifact.load("<your-tree>").view(pd.DataFrame)
table, tree = match_tips(table, tree)
tree.write("<your-new-tree>")

Followed by a qiime2 import

qiime tools import --input-path <your-new-tree> --output-path <your-q2-tree> --type Phylogeny[Rooted]

This is great! Thank you for the investigation and the solution :slight_smile:

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.