Error when installing Aldex2

I have been working on installing Aldex2 (@dgiguer) in my Qiime environment using Ubuntu. As far as I can tell, I have successfully installed the R package, but when I switch back to my Qiime environment to install Aldex2, I get an error. I ran this code:

conda install -c dgiguere q2-aldex2

Then I got this error:

Collecting package metadata (current_repodata.json): done
Solving environment: failed with initial frozen solve. Retrying with flexible solve.
Solving environment: failed with repodata from current_repodata.json, will retry with next repodata source.
Collecting package metadata (repodata.json): done
Solving environment: failed with initial frozen solve. Retrying with flexible solve.
Solving environment:
Found conflicts! Looking for incompatible packages.
This can take several minutes. Press CTRL-C to abort.
UnsatisfiableError: The following specifications were found
to be incompatible with the existing python installation in your environment:

  • q2-aldex2 -> python=3.6
    Your python: python=3.8.15
    If python is on the left-most side of the chain, that's the version you've asked for.
    When python appears to the right, that indicates that the thing on the left is somehow
    not available for the python version you are constrained to. Note that conda will not
    change your python version to a different minor version unless you explicitly specify
    The following specifications were found to be incompatible with your system:
  • feature:/linux-64::__glibc==2.35=0
  • feature:|@/linux-64::__glibc==2.35=0
    Your installed version is: 2.35
    Note that strict channel priority may have removed packages required for satisfiability.

It also hung on the solving environment for over an hour. Is there anything I can do to speed it up?

I tried to install Python 3.6 and got 1000s of lines of conflicts, and python --version still returns 3.8.

Hi @hharder,

That plugin is has not been updated to work with later releases of QIIME 2. I would recommend installing an older version of QIIME 2 for this plugin to work. This is the beauty of installing QIIME 2 via conda, you can have many different versions of QIIME 2 on your system at the same time and activate the version you want to use.

I think the latest version of QIIME 2 that can run this plugin is qiime2-2021.2. I do know that it works well in qiime2-2020.6.

So, I recommend following the install instructions for the respective versions of QIIME 2, and then install the plugin. Remember to always click on the red "Show me the content on this page" notice when navigating these older versions.

I'd also remove and re-install the version of QIIME 2 you tried to force install an older version of python, as you can tell, many things just broke. :slight_smile:

I tried to get a whole new environment and install an old version of Qiime but I still got a ton of conflicts and it didn't install. I thought that working in a new environment would help, but it didn't.

Sounds like there might be an issue with conda setup? Can you provide a screen shot of the errors when you try to setup a new conda environment for QIIME 2?

Thank you @hharder. Let me confer with the :qiime2: team.

I noticed that you are trying to install qiime2-2019.4, this may not work as ALDEx2 was made for qiime2-2019.7 as outlined here, up to and including the versions I mentioned earlier.

I tried following the instructions for 2019.7 as well and I am getting the same error.

I was assuming that to be the case. I just figured I'd ask. Thanks! :slight_smile:

Hi @hharder,

I am wondering if you need to clean and update your conda environment? Try running the set of commands below.

conda remove -n qiime2-2020.6 --all

conda clean --all

conda update conda


conda env create -n qiime2-2020.6 --file qiime2-2020.6-py36-linux-conda.yml

rm qiime2-2020.6-py36-linux-conda.yml

conda activate qiime2-2020.6

Then install the ALDEx2 plugin as outlined.

If the issue still persists, let us know.

Unfortunately this did not work. When I tried to update conda, I had to force it to install by specifying the newest version, which did work. Wget then installed the yml file properly, but conda env create failed in exactly the same way as previously.

:thinking: Hmmm... I am not sure what to suggest next. You may need to uninstall conda completely and re-install. Then install your conda environments.

1 Like