Error when install q2-picrust2

Hello,
I am using qiime2-2019.10 and I like to run q2-picrust2. I followed installation steps in this link :slight_smile:https://library.qiime2.org/plugins/q2-picrust2/13/

But " the plugin version for qiime2-2019.7 is specified"
So, I installed it from the source:

get https://github.com/picrust/picrust2/archive/v2.2.0-b.tar.gz
tar xvzf  v2.2.0-b.tar.gz
cd picrust2-2.2.0-b/

Create and activate the environment (with requirements) and then install PICRUSt2 with pip.

conda env create -f  picrust2-env.yaml
conda activate picrust2
pip install --editable .

Run the tests to verify the installation (note that this wont work if you followed the bioconda install instructions):

pytest

so, when testing, I got this error;
FileNotFoundError: [Errno 2] No such file or directory: ‘picrust2_pipeline.py’: ‘picrust2_pipeline.py’

…/anaconda3/envs/picrust2/lib/python3.6/subprocess.py:1344: FileNotFoundError
===================== 4 failed, 53 passed in 17.52 seconds =======

Is the latest version of q2-picrust2 only compatible with qiime2-2019.7 release?
I do not know what is wrong, I just follow the instructions!
Thanks

Hi @Eman,
Did you try installing q2-picrust as is from the instructions? I don’t think there should be any issues using the 2019.7 version of that plugin with the new q2-version. Give that a go first.
The error you are getting is not qiime2 related as you are actually just installing picrust2 from source in its own environment.
If the first suggestion doesn’t work you can try recruiting help regarding that specific error directly from the picrust2 developers at their github page.

Yes, it is now okay with qiime2-2019.7
Thanks so much

Hi @Eman,
Glad you have it working! Just for closure’s sake here, did you end up using qiime2-2019.10 with regular q2-picrusts2 installation instructions or did you downgrade your environment to q2-2019.7 to get it to work?
My original recommendation was to just use q2-2019.10 and follow the q2-picrust instructions as is, i.e

conda install q2-picrust2=2019.7 -c conda-forge -c bioconda -c gavinmdouglas

I installed qiime2-2019.7 and followed the instructions since the first trial to install picrust2 from source website in qiime2-2019.10 did not work.

Hello,

I ran picrust2 tutorial in qiime2-2019.10 which was okay. But, when I tested the same code on my data, I got this error:
Error: QIIME 2 has no plugin/command named ‘picrust2’.
So I activated picrust2 environment and ran the same code and got this error:
The program ‘qiime’ is currently not installed. You can install it by typing:
sudo apt install qiime

So, I activated q2 version 2019.7 and the code ran successfully.
It is funny, why it worked with version 2019.10 for the tutorial, though version2019. 7 worked with my data that were generated by version 2019.10???
Anyway, I think I have to use version 2019.7 for picrust2.

Thanks!
Eman

Hi @Eman,
Thanks for the update. Can you restart a fresh terminal, run conda env list and then redo the steps that led you to the errors you received, then share with us the exact commands + errors.
My suggestion above would install q2-picrust and NOT picrust from source which I think you may have done eventually? Those are 2 separate and unrelated approaches. So, with your qiime2-2019.10 environment activated, try installing picrust2:

conda install q2-picrust2=2019.7 -c conda-forge -c bioconda -c gavinmdouglas

Note that the q2-picrust2=2019.7 in the above command is referring to the picrust2 version and not qiime2, so leave as is.
If this doesn’t work for some reason then we’ll get the developer of picrust2 to have a proper look at this.
Thanks!

1 Like

[email protected]_Estaki,

I ve activated qiime2-2019.10 and installed picrust2 using

conda install q2-picrust2=2019.7 -c conda-forge -c bioconda -c gavinmdouglas

then tested on a new group of samples and everything is going smoothly without errors.

Your note " Note that the q2-picrust2=2019.7 in the above command is referring to the picrust2 version and not qiime2, so leave as is" clarified what I mistakenly did.

Thanks you!
Eman

2 Likes