Error: Silva132 99% classifer, white space in taxa name

Hi Q2ers!

I recently ran into a problem with the taxaonomy.qza artifact when working with Qiime2-2018.8 and the Silva 132 99% 16S OTUS.

CategoricalMetadataColumn does not support values with leading or trailing whitespace characters. Column ‘Taxon’ has the following value: ‘D_0__Bacteria;D_1__Bacteroidetes;D_2__Ignavibacteria;D_3__OPB56;D_4__uncultured bacterium ’

I tried to filter this entry with qiime taxa filter-table, but this command threw basically the same error. I eventually opened the Silva taxonomy file and removed the offensive white space in the original file and then retrained the classifier. This worked, but it takes a lot of time to remake classifiers.

I googled the error and found that it was previously reported (Qiime taxa filter-table error), but the issue was closed in June.

I just wanted to let you know this is still a problem.

Best wishes and thanks for all your hard work :slight_smile:

1 Like

Thanks for the report @Maggi_Mars --- we still haven't gotten around to addressing the trailing whitespace issue. As well, I wouldn't put too much stock in the forum topic being closed --- all forum topics automatically close after 30 days of activity, but the developer issue xrefed there is still going strong:

Stay tuned, and thanks so much! :t_rex:

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.